Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1 (Edited)
Just like the title, truck runs like a dream at all times but when it rains ill be driving and it runs great then as i come to a stop at a light or something just before the truck comes to a complete stop it just shuts off. I can start it right back up with no problems and it ONLY does this when it rains... I know it is not the CPS cause i thought it was at first so installed a new one then when it started doing it again i replaced new CPS with another NEW CPS just for good measure. It has the new IPR aswell.
Any help would be greatly appreciated.
Derek

Spell check "Braking" not "Breaking"
 

·
Registered
Joined
·
86 Posts
Discussion Starter #2
Any suggestions? Does not do it everytime I stop just like 1/25 ratio and it being hurricane season In FL we have a lot of rain.. I would hate to bring it to a shop for something stupid and easy..
 

·
Registered
Joined
·
2 Posts
We had this problem on our 99 powerstroke and we couldn't figure it out.....come to find out it was just a loose ground. Good luck with it.
 

·
Registered
Joined
·
73 Posts
I have been searching for a thread similiar to this. I have recently been driving my truck and noticed stalls while driving. No rain though and for no apparent reason I will be off the pedal and slowing down when it will die. It has happened twice. The loose ground things peaks my interest since I also am having trouble with my EGT gauge bouncing which was suggested to be a bad ground. bstrack13, how did you fix your loose ground? Where was it located?
 

·
Registered
Joined
·
2 Posts
I have been searching for a thread similiar to this. I have recently been driving my truck and noticed stalls while driving. No rain though and for no apparent reason I will be off the pedal and slowing down when it will die. It has happened twice. The loose ground things peaks my interest since I also am having trouble with my EGT gauge bouncing which was suggested to be a bad ground. bstrack13, how did you fix your loose ground? Where was it located?
It has been a couple of years but it seems like it was a body ground on the passenger side. I really can't remember exactly wher tho.
 

·
Registered
Joined
·
2,236 Posts
my tuck has been doing this recently too. when im stopped at a light and sitting for a bit it stalls out. starts right back up and runs ok, a little rough but not bad. occasionally it will stall out while cruising on the freeway but starts back up on its on. its very rare and cant get it to do it all the time. Recently replaced the UVCharness icp and ipr are both new, going to try a new CPS next?
 

·
Registered
Joined
·
56 Posts
i got the same problem guys. Stalls only when wet, or while driving it will miss then catch itself. I have put a new cps on it and packed the connector with Di-Electric Grease, then pulled the inner driveside fender to try and seal the injector control module better. Still truck stalls. Then i read that the it could be the wiper motor so i drove home today with my wipers on high, low and different clicks of intermediate with no problems at all (no rain today). Only other thing is maybe the windshield is leaking? but i don't think so cause the carpet is never wet. I also heard to replace the whole engine wiring harness cause there could b a bad wire? anyone ever heard that before?thanks kyle
 

·
Registered
Joined
·
56 Posts
Yep did that. I drove home with them on the whole way. I changed from high, low to different settings on intermediate but nothing, ran fine. I replaced the windshield but we haven't had rain yet for me to test that. thanks kyle
 

·
Registered
Joined
·
86 Posts
Discussion Starter #10
Any updates mine still does it from time to time..
 
1 - 10 of 10 Posts
Top