Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
Hey guys,
I tried to put a new head unit in my 2001 ford f250 and i got the head unit to turn on and I was tryin to connect the speakers up and then when I tried turning it back on it wouldnt, so i decided to just put the factory one back in. When I did this the factory one wont come on at all. I checked the fuse and it was blown. I put a new fuse in and still no luck. Any ideas what the problem could be??:dunno:
 

·
Registered
Joined
·
3,393 Posts
make sure the antenna is pushed in all the way they are tricky to get to "seat"
 

·
Registered
Joined
·
72 Posts
Discussion Starter #3
my radio doesnt light up or anything. could that all be cause of the antenna? I get no power at all to my radio it seems like
 

·
Registered
Joined
·
3,393 Posts
yes that antenna acts like a ground i believe check that no lights or anything will come on if the antenna isnt in
 

·
Registered
Joined
·
72 Posts
Discussion Starter #5
I tried re positioning the anntenna and turned the cable took it out and pushed it back in and nothin happened???
 

·
Registered
Joined
·
72 Posts
Discussion Starter #7
I dont think it is the speaker wire, when I turn my keys backwards the stereo does not come on at all..
 

·
Registered
Joined
·
176 Posts
I recently arced something when installing new batteries.
Radio didn't work at all afterwards.
I have a similar problem to the OP.
I checked the fuse under the hood and found it to be blown.
I replaced that 20 fuse and still no power to the radio.

Where is the second fuse? Thanks,
 
1 - 11 of 11 Posts
Top