Ford Powerstroke Diesel Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I have a 2005 XL and the factory XM radio was crap, I took it out and found a ball of wire nuts and electrical tape (pictures included). So my 1 hour deck installation was screeched to a hault, does anyone have any ideas of how to splice my kenworth harness directly to my oem wiring becuase of this issues?

Any ideas or comments will help. Thanks!
 

Attachments

·
Registered
Joined
·
143 Posts
I have a 2005 XL and the factory XM radio was crap, I took it out and found a ball of wire nuts and electrical tape (pictures included). So my 1 hour deck installation was screeched to a hault, does anyone have any ideas of how to splice my kenworth harness directly to my oem wiring becuase of this issues?

Any ideas or comments will help. Thanks!

That's.... unfortunate.

Here is how the factory connector was wired, before someone butchered it for you.




You should be able to find a kit on Ebay with both male and female connectors (with pigtails). That would let you splice a "factory" connector back on to the harness, and splice the other one to your new head unit.


Lee
 

·
Administrator
Joined
·
34,080 Posts
Might want to get an adapter too so you don't have to hard wire it in to the truck. Just plug and play that's what I always do.
how are you going to install this " adapter"?when the OEM plug is gone ?

We have seen guys in this predicament before and finding an oem Harness to splice back in was not working well for them
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
The harness for some reason was cut and as you can see a ball of wire nuts and tape was connecting it. Got some wiring to do but I think I can make it work without buying a new harness. But ya I got the plug and play when I bought the deck
 

·
Registered
Joined
·
143 Posts
how are you going to install this " adapter"?when the OEM plug is gone ?

We have seen guys in this predicament before and finding an oem Harness to splice back in was not working well for them
Well, if you take the pinout I posted above, and use the 24 pin connector in this kit:

Metra Part # 71-5520-1 | Ford wire harness | Lincoln wire harness | Metra Online

You will have effectively restored it back to a factory connection, for which there are other kits available to make it universal plug and play.


Lee
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top