Ford Powerstroke Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,763 Posts
Discussion Starter #1
Got the new mishimoto rad on monday. Got to it last night and this morning. Wasnt to bad, took a few hours. I also swapped hoses, t stats and changed to Cat ELC.
NOt a whole lot to see but heres some pics of process.












 

·
Registered
Joined
·
1,598 Posts
Awesome! I recently put a new rad in my 6.4, but there were no mishimotos in stock. I had to have the truck fixed so it got a vista pro. Although they have plastic tanks, they have a lifetime warranty too. Just wish I could have had the mishimotos for a few hundred dollars more.

After owning a 6.0 and now having a 6.4, I'd say that the rad replacement was one of the easiest things I've done so far. Didn't think it would be as easy as it was.
 

·
Registered
Joined
·
1,763 Posts
Discussion Starter #4
Stats, hoses and cap were $130ish I think?

Worse to do in a 6.0 truck? Given the amount of stuff in the way to get rad in/out its not a bad job. Skinny arms would come in handy in some spots though for sure.
 

·
Registered
Joined
·
1,598 Posts
Worse to do in a 6.0 truck?
Just general fixes not rad specific. After always fixing my 6.0 and laying over the motor for everything, a 6.4 rad looked like no fun. I was done in a couple hrs.:liar:
 

·
Registered
Joined
·
1,763 Posts
Discussion Starter #9
I noticed my EOT and my ECT are much closer all the way to up to operating temp. Havent seen more then 2-3* difference. I was seeing closer to 10 mostly before.
It runs cooler, cools down faster.....which is normally a good thing but in this weather I want the heat!! (-30*c).
I was breaking trail in about 2.5ft of snow in 4hi today just trying to get it up to temp and couldnt get past 194/196*...
 
  • Like
Reactions: Capt dong

·
Registered
Joined
·
1,763 Posts
Discussion Starter #11
Lucky bugger! Is your rad leaking right now? Or precautionary reasons?
 

·
Registered
Joined
·
1,149 Posts
It's been a slow leak for a couple months like a drip here and there. Noticed lately it's been a little more.
 

·
Registered
Joined
·
1,763 Posts
Discussion Starter #14
Only lines I disconnected were 2 trans lines to rad. Wait, maybe it was 3? Anyways, only lost maybe 1/2 liter of atf.
 
1 - 14 of 14 Posts
Top