Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
412 Posts
Discussion Starter #1
The other day i did my STC Fitting, StandPipes and Dplugs, Oil Cooler and EGR Delete on my truck, they were all good but wanted to take care of it before it gets me. Anyway My question is b4 i did the fitting and all my ICP on my CTS would read up to 2500psi or so now it doesnt go over 1900psi or so under a hard acceleration, i drove it probably about 50-60 miles so far any reason why its dropped? Trucks fires up and runs good, and i have vivian economy tune as well. I also disconnected the batteries when i did all the work dont know if that matters
 

·
WWW.COMPIGNTECH.COM
Joined
·
8,777 Posts
Usually tune writers change the icp tables so that the PCM won't cut fuel on top on a hard run this is why you are only seeing say 1900 psi when actually the HPOP is making around 4000psi of HPO.
 

·
Premium Member
Joined
·
11,966 Posts
Forget the psi and check volts. Under WOT it should hit 4.8v and hold 4.7v.
 

·
WWW.COMPIGNTECH.COM
Joined
·
8,777 Posts
See if you were one of us "cool" guys Mitch than you would have a Dashboss that calculates ICP pressure based off of ICP voltage for you and displays it as a PID that is accurate to the voltage reading even while tuned. :poke:
 

·
Registered
Joined
·
412 Posts
Discussion Starter #6
On my insight it got up to 2.3V when I floored it....any idea if its the sensor or wiring maybe? I have Vivian's economy tune on the truck and just did the stc, D plugs and pipes and egt delete as well as new style feed and drain lines for turbo
 

·
Premium Member
Joined
·
11,966 Posts
Try it with the stock tune and see what happens. That voltage is low.


Sorry about the Dashboss. That requires an Apple product and I don own anything Apple.
 
1 - 9 of 9 Posts
Top