Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I picked up a 2000 7.3 about 6 months ago. 240,000 miles.

Previously when I started her up when cold, I would get the blue smoke. Not a big deal I figured. When I plugged in the block heater at night and started in the morning, almost no blue smoke. Seemed appropriate.

Recently, she is smoking even when having been plugged in overnight. Do I need to investigate or OK to leave it?

I'm not new to wrenching but they were always old Toyotas and Jeeps. I'm a new to diesels.

Thanks for any advice.
 

·
Registered
Joined
·
1,637 Posts
What is the condition of the glow plug system (relay and glow plugs)?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Sorry for the delay!

I don't know enough about that system to say anything with confidence. Is there a quick way to verify the system is working properly? If not, I'll begin researching the system so I can diagnose.

Thanks.

so you are confident that the GP system is working properly?
 

·
Registered
Joined
·
1,637 Posts
Is there a quick way to verify the system is working properly?

Thanks.
If you have a meter you can check for battery voltage at the load side of the relay when the key is turned on. Also you can check the voltage difference across the two large posts to see how well the relay is transferring power. You can also pin out the harness at the valve cover to check individual GP circuits to see if they are bad (open).
 
1 - 7 of 7 Posts
Top