Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
So I made a post the other day about my pump. I managed to finally get the right one from napa. But not even two days later it's doing weird stuff like the blown one was. I will be driving and randomly it will not drive in a straight line, it will either pull to the right or pull to the left and sometimes gets stiff around corners once in awhile. Then goes back to being completey normal. Any ideas, starting to drive me crazy!

Thanks.
 

·
Vendor
Joined
·
208 Posts
So I made a post the other day about my pump. I managed to finally get the right one from napa. But not even two days later it's doing weird stuff like the blown one was. I will be driving and randomly it will not drive in a straight line, it will either pull to the right or pull to the left and sometimes gets stiff around corners once in awhile. Then goes back to being completey normal. Any ideas, starting to drive me crazy!

Thanks.
Are you sure it's not the steering gearbox?
 

·
Registered
Joined
·
113 Posts
Discussion Starter #3
I hope not. Just seems odd that it only happens once in awhile, if it was the gear box wouldn't it be all the time?
 

·
Registered
Joined
·
699 Posts
If you are buying a critical parts. Or stuff that is hard to change. Or can cause you to get into an accident. It should not be from napa. You should have bought an oem pump. This is something alot of people dont believe. But the quality of parts is night and day sometimes.

Now, why did you think you needed a power steering pump in the first place? Symptoms?

I would start by checking over the front end

tierods
balljoints
U joints
pitman arm
drag link
steering stabilizer

These can all cause a pull and an occasional binding
 

·
Registered
Joined
·
113 Posts
Discussion Starter #6
I guess I should have added more information. I just replaced the entire front end less then 6 months ago. And I was out doing donuts/burnouts a month ago and cooked the powersteering pump. Yeah I probably shouldn't have done that. But oh well, the pump would barely turn the tires and whining, pretty easy to tell it was dead. Also I have never went cheap on parts for this truck. And usually I get OEM unless the OEM part was an issue from factory.

Thanks.
 

·
Registered
Joined
·
699 Posts
I guess I should have added more information. I just replaced the entire front end less then 6 months ago. And I was out doing donuts/burnouts a month ago and cooked the powersteering pump. Yeah I probably shouldn't have done that. But oh well, the pump would barely turn the tires and whining, pretty easy to tell it was dead. Also I have never went cheap on parts for this truck. And usually I get OEM unless the OEM part was an issue from factory.

Thanks.
Your truck, your money, you get have fun doing whatever you want with it IMO lol

I would say you have air trapped in the system. There is a few different procedures, pick your favorite and start working the air out.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #8
Well any ideas on what the procedures are. I was under the impression that once you install the new pump you just turn the wheel far right and far left. Also it started doing this with the dead powersteering pump as I drove around with the dead one for almost a month. Money was tight otherwise it would have been changed within the same day
 
1 - 8 of 8 Posts
Top