Ford Powerstroke Diesel Forum banner
1 - 7 of 7 Posts

·
Banned
Joined
·
148 Posts
Discussion Starter · #1 ·
2001 F250 4wd auto tranny supercab with 3.73 gears

History....1 year ago fuel mileage was ay down ...right before I started to take it in diode in tranny failed ...had tranny rebuilt locally ....rebuild job failed at 7,000.

Between first and second rebuild which btw builder didn't honor his warranty last phone conversation we had his response was what do you want me to do about it .....

I replaced up-pipes with IH kit no exhuast leaks period ...

I installed pyro/tranny/boost guages

I had PCM reflashed and tranny rebuilt......

I replaced EBPS-cleaned tube/ replaced MAP sensor / ICP+IPR new and replaced both pigtails .....

OK so I get a DP tuner which is great ....I also Installed a BTS valve body ...great as well...

My mods are napa intake / AIH delete / muffler delete no cat ....I installed a AERO TURBINE MUFFLER which I believe is junk didn't like it the second I left the exhuast shop...killed 3-4 psi of boost and my whistle stay away its junk!! GOING THIS WEEKEND TO HAVE IT CUTT OFFMY TRUCK...

OK so after now I have switched to amsoil and rev-x for lube ....my tranny is fine ...

My mileage is like 10-12 chip just makes it worse if you get into it ...


I just replaced my IC boots and hairsprayed and torqued to 9lbs and replaced my HPOP .....

I have rebuilt my fuel bowl and have installed a 67 PSI regulated return ...

I have a high pressure oil crossover pipe installed now

I rebuilt my injectrors which btw were in almost perfect condition NO signs of any real wear or damamge / corrsion ect ....Jim rosewood kit ...so glad I didn't spend 1200.00 on remans or 2500.00 for ford remans !!!!


anyway so all these things and nothing seems to have made that big bang of getting my MPG or power back to even stock levels .....


I have autoenginuity and use it alot ...my last scan after this latest batch of work revealed 1400 psi of ICP at WOT at 90% duty cycle NOT GOOD...it was 500 psi and 12% at idle which is ok i guess but something is amiss here . I bought a NEW Bosch pump not a reman and my old pump would hold 2100-2200 psi WOT and about 475 psi at 11% at idle ...hummm

I also suspect that my IDM/or PCM is goofy I have no misses or hesitation or knocking period ...

Can an IDM / PCM cuase this kind of problem ...if fuel goes in too late into the cylindr IE retearded it produces lest power/torque ...has anyone had this kind of issue or heard about a guys PCM/IDM killing his mielage IE the motor was mechanically sound and the hardware was good his electronics were the culprit ....

The PCM and IDM are 1,000 to replace and I have spent a ton of money on this thing ....and am very very very unhappy with it I know the ICP is horrible ..


James at DP tuner said he knew a guy who had a brand new HPOP and one of his check valves in the output of the pump was installed backwards at the factory and thus he pump looked ok at idle but as soon as you loaded the throttle ICP would nosedive ...due to one side of the pump tryng to supply both heads ....I will investigate this tonight or tommorow by removing old pump output fittings and looking at how those check valves are in ..

BTW my truck when newer used to start right up very very little cranking now it seems to take alot longer not due to lack of oil in resivor but maybe a timing issue?

can an IDM get weak ?? low voltage ..retarded timing ect or a PCM cuase this with no appearant signs like missing stalling ect truck runs idles smooth ....period no codes other than what I cuase myself....


HELP :( I am so over this truck I could puke...my summer and thousands wasted ....on a truck with 70,000 miles ....about ready to take it to ford ....
god forbid

I think I may order a hand held oscilloscope so I can maybe check output of the IDM ...........voltages ....

Help :(
 

·
Johnny Law Brown
Joined
·
366 Posts
I would check your cps and maybe your ipr I know you replaced them but it is possible to get bad parts and idm could be bad if you suspect that I would try swaping one out with a good one or getting from a junk yard first and don't take it to the dealer just keep rooting around here somebody will eventually figure out what is wrong
 

·
Banned
Joined
·
148 Posts
Discussion Starter · #3 ·
Replaced IPR with old one today 15 psi change at idle and 100 PSI change at WOT 1500 PSI chip on 125 race I am going to go do and AE run an data log so i can show you guys how screwed this pump is.....
 

·
Banned
Joined
·
148 Posts
Discussion Starter · #7 ·
Imagine how pissed I was today but at least my wastegate is fixed !!!!

Hopefully my injectors are ok after I get the HPOP sorted out if I have to take em out again and send em to Jim Rosewood I'll be pissed!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top