Ford Powerstroke Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter #1
Hey guys,

i am experiencing some power issues with my truck. It shifts smoothly if i accelerate easy and steadily on flat ground. If i am going up a hill however, or accelerate quickly like 3rd+ on a highway onramp, the truck is very reluctant to shift. it takes like 2000+ rpms to shift.

I had it at the ford dealer for the CPS recall and they said the tranny was fine but #8 injector was shot: i.e. running on 7 cylinders, and thus less power available to the transmission to shift. They replaced it and it seemed fine, but no the problem is back.....

I have experienced a little loss in MPGs and I can ocaisionally get it to shift into the higher gears by really mashing down the gas, but this usually causes a pretty dangerous surge that throws me forward.

Any Ideas? HELP PLEASE!!!


Wes
 

·
Registered
Joined
·
1,363 Posts
Did it shift fine right after the injector was replaced?
 

·
Registered
Joined
·
1,363 Posts
Will it shift into overdrive, is there a check engine light? Does it feel like it is slipping, or just a late shift.
 

·
Registered
Joined
·
422 Posts
Discussion Starter #5
it seemed to shift fine after the injector, but it just doesn't seem to have the it punch it used to.

As for the OD, my light has NEVER been on, i.e. no matter how many times i press the button, it will not turn on or off, plus i can't feel it being in or out of OD if i press the button.

is it possible i have a trans without overdrive?
 

·
Registered
Joined
·
422 Posts
Discussion Starter #6
just drove back up to school....couple big hills at the end: wouldnt get into
3rd until almost 3000rpm! There must be some significant lack of power that is causing this...only other option is maybe my trans fluid needs changing? seems llike this is too serious for that though
 

·
Registered
Joined
·
2,033 Posts
have you had your compute scanned?? i recently have power problems also. ended up being my IDM was dying.
 

·
Registered
Joined
·
422 Posts
Discussion Starter #8
have not had it scanned...is it easy to swap for a new IDM or am i gonna have to get the dealer to do that?
 

·
Registered
Joined
·
2,033 Posts
have not had it scanned...is it easy to swap for a new IDM or am i gonna have to get the dealer to do that?
it's easy to swap out, you can do it yourself. first, found out what is wrong. if it's IDM, it'll cost you about $1100 for a new one. they are so Ford specific, the IH dealer doesn't have it.
 

·
Registered
Joined
·
43 Posts
Its not a IDM problem, if you light doesnt work, it should come on when you press the button, if no you need to probably replace the button on the shifter. i would have it scanned for codes, it may have some tranny codes. I would NOT spend any money on the IDM.
 

·
Registered
Joined
·
422 Posts
Discussion Starter #11
the manual says that OD gets reset to On every time the ignition is turned on....would this not happen if the switch is bad? i.e. could the thing be stuck with OD off?
 

·
International Threat
Joined
·
13,087 Posts
Wes I know you've been around here for a while, you need to let us know where you're located as well as get the veh scanned by a good scanner....

After that, myself... scuffy... marc... or similar could view the info posted and let you know where to go from there :thumb:
 

·
Registered
Joined
·
43 Posts
No its not kicking overdrive off by itself, you probably have a faulty button b/c yours wont light up when you press the button, and the light and button are an assembly, and if the light doesnt come on when you press the button, it wont flash when there is a transmission fault, i would reccomment replacing the button/light assembly on the shifter, and seeing if the light will work then. If it does work after you replace it, if you do have transmission problems it will flash. Sorry this is kinda confusing, but i hope it helps.
 

·
Registered
Joined
·
360 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter #15
I live in southern new jersey. My truck is an 01 f250 with 50k miles. i have done nothing to it except maintenence.

i had this same problem back in march when i had the truck go in for the CPS swap. they found no tranny codes. did find #8 injector not firing...it was replaced.

I am up at college for another week, then i will get it scanned when i get home.
 
1 - 15 of 15 Posts
Top