Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
589 Posts
Discussion Starter #1
I let my truck warm up every morning at least 5 ten minutes before I take off. So its pretty warmed up. When I take off and get to about 2000 to 2500 rpms it jus cuts out bad and acts like an injector.Then if I floor it and drive it hard it will seem to clean out and run fine. Soon as its good and warmed up runs like a champ. Fuel filters always changed. I had it at ford about 3 months ago and had #7 injector replaced and they said the rest were fine. Then ran like crap took it back and the egr valve went out. So I replaced that.Also has a new fuel pump to cause that also went out. Now it still does it. If anybody has any ideas of what to do or what it is i would appreciate it. I am thinking of going in and having the computer reflashed and have injectors checked again though.
 

·
Registered
Joined
·
420 Posts
What kinds of S & S are you having? any like this

Rought cold starts
Rough until warming temp
lack of power until warming temp
miss firing

If you have any of those then its an injector. All it takes is just one to fail and you will get what your saying so answer those questions above and we can go from there
 

·
Registered
Joined
·
1,933 Posts
mine acts the same way .....
 

·
Registered
Joined
·
4,057 Posts
Where's dave when ya need him.
 

·
Rice Hunter
Joined
·
4,036 Posts
Try some good fuel additive! Diesel Kleen etc.
Wish Ya Luck!!
 

·
Registered
Joined
·
1,933 Posts
so they could be just plugged or some of them
 

·
Registered
Joined
·
589 Posts
Discussion Starter #7
I run the additive all the time. Kinda makes a diff but not really. It starts fine, idles fine, and takes off fine but then it just takes a crap in the midrange. Im gettn an sct so guess il just go down to ford and get it checked and puter reflashed
 
1 - 7 of 7 Posts
Top