Ford Powerstroke Diesel Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
Hey guys, been running my truck on the economy setting for a good while now, and decided to have some fun today on the way home from classes. I noticed a few strange things happening at one time since last night.
1. I have burned about twice as much fuel as usual since I filled up last night. (1/2 tank, usually only a quarter)
2. My needle on the boost gauge is vibrating wildly above 20 psi
3. The truck seems less responsive, and has a noticeable power loss.
4.The usual black cloud I leave behind me seems much more grey and hazy than before.

My buddy suggested the idea that one of my injectors may be tripping up. I'm not sure.

Any thoughts on the problem here?
 

·
BANNED by Kris
Joined
·
6,322 Posts
Are you running Stage II's on the stock turbo? Wow. I'd look for a boost leak right off. The stock system wasn't designed to go above 16 Psi (through I've had mine to 27psi).
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #3 ·
27? Mine has been over 30 at times when I forget to restrict myself... Sometimes its hard not to. A local HD mechanic also suggested that it may be a boost leak...
my question is: What is the easiest way to check?

Also, slightly off subject but I'm planning to run about the same setup (Current mods in signature plus T500 HPOP, SD Intercooler, D66, E-Fuel) as what is in your signature by the end of next summer.. Do you like the performance from yours?

Thank you
 

·
BANNED by Kris
Joined
·
6,322 Posts
L-O-V-E my current set-up but want MORE! Around town is nice with plenty of giddyap. Average 17.3 MPGs but with winter rollingin that is slowly dropping. Tows nice too.

Ok boost leaks, looks like your induction system is still pretty stock. This means a leak in one (or more) of three spots. Pull the intake Y-Pipe off and make sure the o-ring from the turbo to the Y is still there and soft/pliable. Check the boots for tightness at all four hose clamps and check the insides for cracks and holes. Last look all the way around the intake plenums to see if your boost level has pushed out the seal to the heads. While the Y-Pipe is off check the inducer wheel for any damage or play in any direction (up, down, left, right, in, out). Now look for any oil from the intake path running down into the heads from the turbo or before.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #5 ·
Thanks a lot bud. Its getting pretty late tonight, but I don't have classes tomorrow so I'll check it out tomorrow morning as soon as I'm up and report back when I've looked all those spots over. I really appreciate the specifics on where to check.

Also, I'm glad you have good things to say about your setup.. but it makes me anxious to finish mine haha
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #6 ·
Turned out to be my ebps.. cleaned it out and everything is normal now :thumb:
 

·
BANNED by Kris
Joined
·
6,322 Posts
Good to know. I have not seen/heard this to be an issue on the pre-97's will keep that in mind for the future.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top