Ford Powerstroke Diesel Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
1,124 Posts
Discussion Starter #1
I have been noticing that some times i have low power when taking off and some times it is fine. Last night I was talking to friends while the truck was idleing. I could here the turbo cutting off and on. It sounded just like when i have unpluged the VGT actuator and pluged it back in. You here the exhuast get louder and then you here the turbo noise. Has any one seen this? Could i have a bad EGT Actuator. Please advise ASAP i am leaving in the morning pulling my travel trailer and i dont want to have any problems. Thanks
 

·
Premium Member
Joined
·
1,124 Posts
Discussion Starter #3
No have not cleaned the turbo. How is that done?
 

·
Premium Member
Joined
·
1,124 Posts
Discussion Starter #6
Thanks. Ill look into that after my trip.
 

·
Registered
Joined
·
67 Posts
If you have the opportunity to run your truck hard during your trip, do so. You can burn off alot of that build that can contribute to the sticking
 

·
Premium Member
Joined
·
1,124 Posts
Discussion Starter #8
Well I ran it hard. I pulled my camper for over 600 miles and got on it several times when normal driving it with out pulling. I think its getting worse. I could really tell when pulling from a stop. It would wind the engine up alot and the boost would be around 10 and it seems like it took a while for me to get up to speed. Once it got up to speed i could just barly push the pedal and it would pull great and boost would run up like normal. You can literally stand by the exhaust and here it spool up and then just shut off then spool up again. it sounds exactly like one does when you first crank it, then it shuts off and back on. It reminds me of what it sounds like when i have unpluged the vgt solonid thing. Could it realy be that the turbo is dirty or could this solonid be bad? Thanks
 

·
Registered
Joined
·
597 Posts
VGT turbos sticking is pretty common. Has it set any code/Check engine lights??
 

·
Premium Member
Joined
·
1,124 Posts
Discussion Starter #10
No lights. I dont have a scanner to see if there are any codes.
 

·
Registered
Joined
·
597 Posts
Well since you don't have a scan tool, or any way to command the VGT solenoid on/off to check is operation, a physical inspection is about all you can do besides checking the resistance of the VGT solenoid.
 

·
Premium Member
Joined
·
1,124 Posts
Discussion Starter #12
My Brother in Law has a 2004 so I can probably swap out his VGT solenoid and see if that fixes my issue. If not then ill yank off the turbo and see what I can find.
 
1 - 12 of 12 Posts
Top