Ford Powerstroke Diesel Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Okay, so. Was driving on the highway home after replacing the water pump. Hit a huge pot hole while starting up a hill. Pedal felt dead then kinda came back about 25% power, looked behind me to see pure white smoke. Pulled over immediately turned it off. Checked the tuner and all temps were normal. Waited 20 min and turned it back on. Truck ran awful almost like it wanted to stall and very quiet. Hooked a snap on scan tool up and it said it had codes for 1,3 and 8 injectors as a circuit code. Anyone else ever have this happen?
05 f250 6.0
 

·
Premium Member
Joined
·
7,598 Posts
Check your FICM plugs
 

·
Registered
Joined
·
56 Posts
also check your plugs on the driver fender well area behind the battery...
 

·
Registered
2004 Ford excursion
Joined
·
3 Posts
same thing happened to me and after doing some investigation under the hood i found my coolant looking like a yummy milkshake lol ..... Reason why i had clouds blowing out the back like cheech n chong So called a shop nearby and explained my situation and was told it was a bad egr cooler... towed it to the shop swap out the egr n oil cooler plus add a coolant filter for extra Insurance that it wont happen again
 

·
Registered
Joined
·
56 Posts
Looks like a wire issue to me, check ALL plugs for wear/ grounding and connectivity manually look for wear at shielding near plugs and all rub points.
 
  • Like
Reactions: Diesel.Dime

·
Registered
Joined
·
56 Posts
Was there water in the hole ?
 

·
Registered
2004 Ford excursion
Joined
·
3 Posts
have u checked your ficm voltage that’s at 48v ford recommends 45v is good anything under that is bad
 

·
Registered
Joined
·
56 Posts
The pothole you hit... could the connections have been covered in water?
 
1 - 14 of 14 Posts
Top