Ford Powerstroke Diesel Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2001f350 cclb 4x4 and I remember getting 17.75 mpg. I take excellent care of the truck and change oil every 3,000 and use the more expensive synthetic. I took it to the dealer because the toque converter check valve was bleeding the transmission in the summer, no issue other than it took up to 10 sec to engage and then would drive great until parked. They installed a new transmission 7/100k warranty at 104k. Great, let's get hauling, not so fast, terrible oil leak. I assumed it was the rear main! They insisted it was the injector pump, great replace it and let's get hauling? $1300 later it's on the road, hmmmm, still leaking. Ok they replace the rear mail. Let's get hauling?? Nope, still leaking, apparently the injector pump was not sealing, new gasket, let's get hauling??? Nope, [email protected] leaking. New injector pump installed, runs great. Fuel economy cruising 70-75 mph for 750 miles is just over 12? It's been this way for a while, vie considered doing upgrades but I'd like to get back to the 17.75 first. I have an edge attitude with juice set at mileage and an AFE air filter/intake setup. What can it be? I've noticed that the truck decelerates quickly almost as though it is downshifting and using the engine to brake. It also seems to take a lot of pedal to get it going. If I really get into the pedal it will go like crazy but I just don't drive that way. Brakes were replaced and rotors turned and the truck doesn't pull to one side. Something isn't right, please help! 15 mpg would make me pee!
 

·
Banned
Joined
·
3,771 Posts
ok wow first of all if your hpop was leaking... you dont replace it, you change orings... it could also be the orings on the turbo pedestal or the EBPV actuator valve...uh feels sluggish? are you sure they didnt accidently install a 15* hpop instead of a new 17*? you really should go to a trustworthy independent mechanic because obviously(no offense) you dont understand these motors and how things work.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks but you're not offering help here.

ok wow first of all if your hpop was leaking... you dont replace it, you change orings... it could also be the orings on the turbo pedestal or the EBPV actuator valve...uh feels sluggish? are you sure they didnt accidently install a 15* hpop instead of a new 17*? you really should go to a trustworthy independent mechanic because obviously(no offense) you dont understand these motors and how things work.
It sounds like you know exactly what's going on here? I've never owned a diesel before, I tow all the time and used a 460 until I purchased this truck. I've been so busy working this truck I've taken no time to learn. With reckless trust I believed in my local dealer. Not doing this again, I think everyone handles business the way I do, guess not? Please give me a play by play on what I should do next. Thanks for any help you can offer, L.
 

·
Banned
Joined
·
3,771 Posts
Have you checked/changed your fuel filter recently? Thats alotta fuel to be wasting. When did the fuel mileage change?? it could definitely be winter blend fuel causing it to drop. If you have any more oil leaks check the areas i said.
 

·
Registered
Joined
·
166 Posts
Check for fuel leak at fuel drain valve.....any leak that will go into the valley of the engine will drain out a rear exit hole in the block and drain down and look like a rear main seal leaking. Could explain low fule mileage and leak.

Adrian
 

·
Registered
Joined
·
457 Posts
At 75 you wont get very good milage. Now that it is cold out, your milage
will drop also. Drive a half a tank and dont go over 65, accelerate like
your garandma and see what you get. Wont be the summer 17.5, but will be
about 16.6-17 in the winter. Even in Tx I get worse milage in the winter from
the "winter" blend fuel.
 
1 - 7 of 7 Posts
Top