Ford Powerstroke Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
2005 Ford F-350 King Ranch 4D 8ft Bed
Joined
·
2 Posts
Discussion Starter · #1 ·
I have talked to multiple transmission shops about my issue and one diesel shop. Some say it’s my reverse solenoid going out others say it’s not a transmission problem is an engine problem because the RPMs don’t go up. I really hope someone can help me out with this. so sometimes whenever I put my truck in reverse I press the gas and it doesn’t matter how much you press it the RPMs never reach above 1000 RPMs. But I can be in the same spot put it in neutral and press the gas and RPMs go up. The only time it will back up when this occurs it’s when I put it in four-wheel-drive low. also it only happens sometimes. If anyone has had the same problem i’d greatly appreciate the help.
 

·
Administrator
Joined
·
32,970 Posts
thats strange seems like the engine should rev no matter what gear the tranny is in even if the tranny was bound up in reverse it seems like you should feel the engine struggle
 

·
Registered
Joined
·
113 Posts
I had a similar problem but in all gears. In park or neutral I could rev to redline but in gear and under load would not go over 1500rpm or so. My problem was a clogged fuel line. The rubber foot in the fuel tank was breaking apart and some got stuck in the line. New foot and fuel filters and blew out the lines from tank to engine fixed it. Not sure if that’s your issue.


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top