Ford Powerstroke Diesel Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
OK guys, my uncle has an '03 F350 with a 7.3; he recently had a mechanic replace some fuel injectors and the injector drive module. After this, the truck developed new issues. First... dead batteries, two new batteries, no problem. Then... dead batteries again, new alternator, OK. Now, while driving, if you slow down for a red light or stop sign; a list of things are subject to happen. 1st) The gauges and radio shut down. 2nd) ABS and seat belt lights come on and/or flash. 3rd) The engine shuts off. After this, it shows all the signs of a dead battery. It can be hooked to another vehicle, a battery charger or a jump box and will start in just a couple of minutes. It may do fine for 15 minutes, 12 hours or 2 days; then the same thing. Please tell me one of you guys has a good idea on this one.
 

· Registered
Joined
·
6,125 Posts
sounds like a bad GEM module. or a short in the harness.
 

· Premium Member
Joined
·
9,839 Posts
Sounds to me like the whole system just ran-out of juice....

All kinds of crazy stuff happens as the Voltage drops too Low and then you say the engine dies at idle and the batteries are Dead - right?

This sounds intermittent, and that can be tricky to catch as it happens. I would have a volt meter on the seat next to me (connected to the Outlet in the cab) and keep an eye on what's going on ;)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top