Ford Powerstroke Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello. I have a 1999 f250 7.3 6 speed. I am having issues with my PCM diode located in the fuse box under the hood.

Every four months or so the truck will begin surging while pressing on the gas pedal. Once this happens the diode will blow within a few days and require replacement before the truck will start. When the diode does go the truck will turn over but the wait to start and check engine lights do not illuminate.

I have taken it to a shop numerous times and they always tell me it's the gas pedal assembly and it must be replaced. "I've replaced it three times now". I'm convinced this is a different issue. When the diode is replaced the truck runs like a champ. Any ideas?
 

·
Premium Member
Joined
·
9,066 Posts
OK First, I think you mean "Fuse"?? (certainly not "Diode"...)

So, is this Fuse 22 by any chance?

If not, EXACTLY which fuse is it?

If so, unplug the Fuel Heater Element in the bottom of the Filter Housing.
 

·
Registered
Joined
·
1 Posts
I too have a blown pcm "diode" have not found the cause, the engine is very hard starting cold and wont start at all right now. i have tried many things but no help. if i figure it out i will post it. i will also watch this thread in case you figure it out.
 

·
Registered
Joined
·
8,562 Posts
unplug the Fuel Heater Element in the bottom of the Filter Housing.
Do this. And most likely you have a bad glow plug relay also. The stock ones are junk.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top