Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
So my passenger door would lock with the buttons or key fob but wouldn't unlock. Later it wouldn't unlock or lock so I assumed the actuator was dead so I ordered one and installed it but didn't fix my issue. I've looked at all the wires in the door and no signs of wire damage. Any thoughts on what my issue may be?
 

·
Registered
Joined
·
119 Posts
Discussion Starter #4
Okay so I was messing around with the wires around the rke module and now my driver's door lock actuator doesn't work either. When I press lock or unlock on the buttons or with the key fob I hear a clicking sound in the rke box. But nothing happens to the actuators. What could be my problem now?
 

·
Premium Member
Joined
·
3,284 Posts
Sounds like cracked solder joints on the connector plug where it connects to the circuit board -- I have not had one of your model year apart, but if the cover comes off, you can inspect the connections with a magnifier and good light -- and if you have the ability, re-flow the solder
 

·
Registered
Joined
·
119 Posts
Discussion Starter #8
Alright, all the wiring looks fine so I am assuming that some of the relays or whatever are burnt up inside of the module. I may go to a salvage yard and pull me one to test if it's my issue. I wish someone made a more modern plug and play module to replace it with.
 

·
Premium Member
Joined
·
3,284 Posts
May want to check the harness in the hinge area of the door -- I have seen some pretty bad chewed/broken wires inside the boot
 

·
Registered
Joined
·
119 Posts
Discussion Starter #10
I've looked there too. My dad's 2006 Dodge ram had that issue so I had assumed that was it but nope. I found a plug the may be the issue. I'm going to mess with it a little bit and try to fix it.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #11
It's been about a month since I fixed the issue and what it ended up being the module itself. Everything looked fine in the old one but whatever, it works now.
 
1 - 11 of 11 Posts
Top