Ford Powerstroke Diesel Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
2012 F250. I replaced it the first time when the truck had 115K on the clock. Now, I'm at 147K and I got the error again. We did have a spell of super cold weather the same weekend that it came back on. I cleared the code and it came back.

I've found plenty of posts about the failure and the TSB, but curious whether folks are having repeated failures. Ford covered it the first time, but I suspect that they wouldn't cover it now that it is well outside their warranty.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
its 50/50. It just sucks to be honest. Many have done the repair on their own using motorcraft parts. I saw one guy find a way to add some insulation to that area to help too. I haven't been able to find pics lately though.
50-50 in terms of having a repeated failure or in terms of having ford pay for it outside of the warranty?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 · (Edited)
The line from the pump to the injector can trip this. It's heated as well and is available as a separate part.
How is that diagnosed/ruled out? How easy is it to access? [Update: just watched a video showing how it is removed. So, I guess what I need to know is which parts to order. Looks like there's no way to know till the tank is removed and the resistance is tested on the heater and then pump.]
 

·
Registered
Joined
·
2 Posts
Yeah... it's pretty easy to check it once you can access the plugs. If your scanner is up to it, the full code will help. I believe its P20BE, but don't quote me on it. People get sucked into the "heater" part of it and assume its the tank itself when it's actually the heater in the line.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
ah-ha! I did get several codes when I checked it again, a few days after the first error showed up. I'll check it again.

Since we are headed into warmer months, are there any drivability issues with the CEL on? I'd like to reduce the amount of fluid in the tank before I drop the thing.
 

·
Registered
Joined
·
1,874 Posts
I drove around and hauled a bit with mine for several months, and not through the warmer months (November to February), and had very little drivability issues. It was maybe slightly down on power but that could have been in my head since i was staring down at a CEL all the time. You should be fine to drive it till it gets cold.
 
  • Like
Reactions: Sphinx

·
Registered
Joined
·
55 Posts
If it was a stand alone code of p20ba, then yes failed heater all day. But if there's other codes could be anything from a pushed out pin getting bad connection to a GPCM failure and everything between. What are the other codes? If it is an issue greater than the heater you could be derated in power eventually. For example if the reductant level sensors fail you may have a full tank of def but it could read as empty. If you get a list of all codes, not just what you think is connected but all codes that show up, I can possibly provide the Ford pinpoint testing that would apply.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
If it was a stand alone code of p20ba, then yes failed heater all day. But if there's other codes could be anything from a pushed out pin getting bad connection to a GPCM failure and everything between. What are the other codes? If it is an issue greater than the heater you could be derated in power eventually. For example if the reductant level sensors fail you may have a full tank of def but it could read as empty. If you get a list of all codes, not just what you think is connected but all codes that show up, I can possibly provide the Ford pinpoint testing that would apply.
Definitely a stand alone P20BA. Been waiting till the tank gives me the 500 miles left warning before I did the project. Any thoughts on brands of heaters? Rock auto sells a bunch of different brands and the ford ones have now failed twice.
 

·
Premium Member
Joined
·
302 Posts
OEM is Bosch. When I replaced mine, I went with Bosch (purchased from Rock Auto) and haven't had any issues since.
 
1 - 13 of 13 Posts
Top