Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,343 Posts
Discussion Starter #1
Full egr delete for years.

just all of the sudden these popped up.

Tried new EGR valve, yes its plugged in.

Butterfly in throttle plate is removed all sensors plugged in.

Tried clearing by getting the truck up to temp and disconnecting batteries for 20 minutes and turning on lights etc.

Brought it in to Ford Dealership and they said the truck runs great and that I need a new EGR throttle plate assembly (like 350 bones!!!).

wtf wtl I am at my wits end. Tried unplugging and looked for wire chaffing.

anything else you can think of?
 

·
Registered
Joined
·
624 Posts
From what I've heard, the p1000 is nothing to worry about. Not sure what the others are?
 

·
Registered
Joined
·
4,914 Posts
You may need to perform the turbo relearn procedure.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
1,343 Posts
Discussion Starter #4
shouldn't that happen when I disconnected the batteries and reset the computer?
 

·
Registered
Joined
·
4,914 Posts
shouldn't that happen when I disconnected the batteries and reset the computer?
No sir, google the procedure, see if it applies to your MY. I think it does.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
1,343 Posts
Discussion Starter #6
7 months later I figured this out!

part number 4c3z9b989b, throttle position sensor

installed and immediately my P0407 and P0488 cleared. You will need the security torx screw to remove.

2004 6.0 had two options a 4 pin and a 6 pin. Mine was a 6 pin throttle position sensor.

Hope this helps someone in the future
 

·
Registered
Joined
·
4,914 Posts
Thanks for the update.

Sent from my phone that somebody didn't help me get.
 
1 - 7 of 7 Posts
Top