Ford Powerstroke Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello to everyone .....
My truck : 2000' F350 4x4 C.C. shortbed 7.3 autotrans , w/many upgrades.
Question : After driving appox. 2 hrs or maybe a couple hunderd miles , towing or not , my overdrive light on the shifter stalk begins to flash ..... if i pull over , shut off the engine , then restart it , the light quits flashing and i'm able to drive again for about the same time frame before it repeats . If i contniue to drive after the light starts flashing , say 10 or more miles , i notice a change in the shifting pattern .... it becomes harsh as the tranny shifts from one gear to the next . This happened with the stock , org. trans as well as the one i have now ... a unit from Sun Coast Transmissions , a severe duty model w/ many upgrades internally as well as billet convertor and larger cooler . The truck has appox. 122,000 miles on it , the new trans , appox. 18,000 miles . Thank you in advance of your helpful replys .

~ Bob ~
 

·
Registered
Joined
·
680 Posts
I believe a flashing o/d light is like a check engine light for the trans. Sounds like there is a code and the trans is goes into "limp mode"
 

·
Shaking the Bush Boss
Joined
·
9,740 Posts
Yep, its the cel for the trans, go get the codes pulled. Hopefully its something simple, sensor going bad maybe.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks guys for your input ... i will have the speed sensor checked out and or replaced .
I do have a question for you Flyin Hawaiian : which fuse are you refering to ?
 

·
Registered
Joined
·
6,168 Posts
Thanks guys for your input ... i will have the speed sensor checked out and or replaced .
I do have a question for you Flyin Hawaiian : which fuse are you refering to ?


Try unplugging the the speed sensor and cleaning the connector, then get some dielectric grease and coat everything good. Also do the same thing with the main harness where it connects to the trans.

Most likely it is the Speed sensor, but if your not noticing any speedo issues it could be other issues.

Please find me the fuse number FH...:doh:
 

·
Registered
Joined
·
3,408 Posts
My E-350 van is doin' the somethin like this too... flashing O/D light... shifts funny when doin' it', speedo stoped working the other day, after the O/D light came on, and it was shiftin' funny, speedo worked intermitently... otherwise runs ok... from reading the past posts, it sounds like my problem is more likely a sensor? After a shut down/restart, all seems to be ok for a while... a week, a few days.
 

·
Registered
Joined
·
5 Posts
Remove the speed sensor from the top of the rear differential housing and clean the face of the sensor and then replace. The sensors are magnitized and pick up metal particles from gear wear and causes the sensors to read a false reading. I have had this happen to many of the trucks that I have owned and also quite a few of my friends and family. Sometimes it is actually a bad sensor and cleaning will not help.
 

·
Registered
Joined
·
74 Posts
Flashing O D Light

If your OD light is flashing. You need to get the codes read.
Your OD Light acts as the Check Engine light for our trucks. If it flashing there are codes.
However not all code readers can read all codes for our trucks. I work part time at Advance Auto adr the reader that we have there WILL NOT read the codes from my truck. I had to take to a shop and have the codes read with their Snap On reader. Good Luck

Rick
 

·
Registered
Joined
·
177 Posts
I agree on getting the codes read. There are several codes that can relate to the trans. (If it was a fuse, it wouldn't "Fix" itself for several miles,, would it?) I have never seen a blown fuse do that...LOL (By "Fixing itself" If the light goes out and the tranny shifts fine for a while.... then goes bad again)
 
1 - 13 of 13 Posts
Top