Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
OK, SO THIS HAS ME CONFUSED FOR A WHILE NOW, I WORK AWAY FROM HOME A GOOD BIT SO MY TRUCK SITS BUT IT GETS STARTED AND RUN ABOUT ONCE EVERY WEEK. WHEN I COME HOME AND START IT TO GO FOR A DRIVE, SEEMS IT RUNS PERFECT. BOOST IS GOOD CAN FEEL THE POWER IN THE PEDDLE. NOW AFTER RUNNING FOR AWHILE, AND GOIN PLACES AND TURNING TRUCK OFF THEN BACK ON WHEN I LEAVE, ITS EITHER IT OVERBOOST OR UNDERBOOST. DEPENDING ON HOW THE TRUCK FEELS LOL. BUT HERE IS THE WIERD PART, IF I UNPLUG BATTERIES AND LET IT SIT FOR ABOUT 30 MIN THEN PUT THEM BACK ON, IT RUNS FINE.. 9/10 IT DOES THAT , IT OVERBOOST ALOT VERY RARELY BUT IT STILL OVERBOOST, I CAN FLOOR IT AND IT HIT 26 POUNDS IN A SPLIT SECOND... SO HOPEFULLY SOMEBODY CAN HELP ME FIGURE OUT WTF IS GOIN ON... OTHER THAN NO ISSUES EXCEPT THE RANDOM BATTERY LIGHT THAT COMES ON AND I DO NOTICE WHEN IT COMES ON, IT RUNS LIKE A TURD WITH THE OVERBOOST. HAS EGR DELETE ON IT 150,000 MILES NO STUDS YET BUT MAINLY HAVENT HAD MANY ISSUES EXCEPT ONE INJECTOR WAS GOIN BAD AND POWER STEERING HOSE POPPED OFF. SO ANYBODY ELSE HAD THIS ISSUE??
 

·
Registered
Joined
·
4,914 Posts
Maybe turbo unison ring sticking, and the 03 has a turbo relearn procedure when the batteries are disconnected. You need a monitor on that truck like edge insight. Check your batteries, bad batteries can kill ficms, and injectors. No need to type in all caps.

Sent from my phone that somebody didn't help me get.
 

·
Premium Member
Joined
·
6,293 Posts
Sounds like you are looking at a good turbo cleaning.
I see you live in a high humidity area, and condensation within the turbo will create the issue you describe. The unison ring is what controls the variable vanes in the turbo, and if rust forms on that (or its mating surface on the turbo body), it will interfere with the unison rings free movement.

CLICK HERE and download the "turbo removal" and the "Ford turbo cleaning" .pdf files for detailed directions on "how to."
Parts of linked post will also help you along the way.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Sorry for the all caps lol. Yea high humidy. What I don't understand is how Un plugging if the batteries brings it back to normal, and also I do have edge monitor. Shows boost and rpm. But it used to show exhaust temp but now it just stays on 1100. And backdown stays at 0%. ... But my ficm should still be good if it still runs good sometimes I hope. And def gonna get the turbo cleaned


Sent from my iPhone using Autoguide
 
1 - 4 of 4 Posts
Top