Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
I bought this truck last winter in WA.

We bought a 16' enclosed trailer and sort of converted it to a toy hauler/camper. Have a Sportster and a Can Am Spyder that we took along.

We drove from OR to the UP of MI via Boise and back. Over 5K miles.

I was a bit concerned about my oil/coolant temp deltas. I run about 11 degree difference when checking it according to the Ford spec sheet.

The truck ran without a hitch. Used no oil. Had to add a few cups of antifreeze, but that was low from a blue spring install(disconnected the top radiator hose at the radiator) and a coolant filter install.

My EOT maxed one time at around 248 and the coolant reached close to 230 one time. I took it easy over some of the hills..slowed down to 45 instead of pushing the speed limit. That seemed to help some.

Anyway, I m still on the fence with the cooling system flush/oil cooler change. I m not sure if it needs it yet. The coolant is really clean. The filter I took off had no dirt in it, at least nothing visible.

Anyway, we had a great time, truck ran flawlessly, Life is Good!!

Brad,back in OR.(and tired of driving his truck!)
 

·
Registered
Joined
·
3,254 Posts
Sounds like everything went well. That was a long trip.

Time to change the oil and give her a rest. A little more good weather for a few weeks, jump on your other ride, and go sight seeing a little closer to home!

And, by the way, you will miss driving it in a few days!
 
1 - 2 of 2 Posts
Top