Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #1
Can anyone tell me what this is. It's a long tube like part just behind where the heater cord goes into block. Looks like oil filter, heater cord and this tube is one piece. Oil is pouring out of it. Wish I had a drop light to really have a good look at it cause flashlight isn't cutting it :doh:. Going to buy one tomorrow and have me a good well lit look. It's just behind orange cord. Hope the pic helps
 

·
Registered
Joined
·
38 Posts
Its your oil cooler. It uses coolant to keep the engine oil cool. It has two o-rings in each end that keep the coolant and oil sperate. One of the o-rings has probably failed. Make sure you don't have coolant in your oil if you're still driving it.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #3
Thanks. Never new my old 7.3 had oil cooler. I know my newer 6.0 has one. Oil still black with no sign of coolant. It's my work truck which has been sitting idle :banghead:. Just drove it home from where I keep my equipment and noticed oil everywhere. Once again thanks
 

·
Registered
Joined
·
582 Posts
Its not too bad to fix. There's only 5 (I think) bolts in it, but you will have to at least jack up one side of the engine to remove it. Also, flush the coolant system while you're at it. Cheap insurance will always be less than an expensive fix.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #7
Finally had the time to fix it. Wasn't to bad to do. Next is glow plugs and need to replace some coolant hoses and the list goes on. The salt hasn't been nice to it
 
1 - 7 of 7 Posts
Top