Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So I have an 05 6.0 F350 160K miles.

I have replaced the EGR cooler with a bullet proof cooler , replaced the the oil cooler with an OEM cooler , less than a year ago or 10K miles.

I installed the S&B intake system ans have altered the catalytic converter.

I run a mishimoto radiator with a mishimoto thermostat ( 186 thermostat) In the last 30 days I have replaced the IPR sensor , the EBP sensor and the EGR valve itself.

So my question is why would I still routinely see a delta between the OCT and ECT in the twenties? The EOT does cool down but may never get within 15 delta points. And the truck does not throw any codes. My mechanic says its due to the truck not getting hot enough to throw a code. And I'm nearly certain the EOT and ECT are synched because when I start the truck up cold both temps are within 2 or 3 delta points , the truck will ride farily close until the ECT reaches 186 or 190 , the EOT continues to climb and will generally stay 24 to 27 delta points within the ECT.
EdgeCTS2.jpg



Any insight and or suggestions would be appreciated.
 

·
Registered
Joined
·
3,822 Posts
Try getting the temps before truck start up. If you suspect the temps don’t match you can swap the EOT and ECT and see if the delta changes. If it does, one of the sensors is probably bad.

Its very easy to clog an oils cooler, especially after an oil cooler swap that did not include a good attention to detail flush that gets the crud out that clogged the system. I clogged mine after a poor coolant flush.
 
1 - 2 of 2 Posts
Top