Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey everybody
I've got a 99.5 SD 7.3 and it's got a wierd issue. Up until a couple days ago the truck would hit 17-18psi boost all day starting at around 1200 rpm with max at just over 2000rpm. Now the truck isn't hitting that boost until closer to 2600rpm and it seems to only get to 10psi at around 1400rpm, where it drops 1 or 2 psi then rises again to maybe a max of 15 or 16. It seems to be better once the engine is fully warmed, and I never drive it without letting it warm up until the temp at least registers on the gauge. The entire change was extremely quick, no building symptoms, just all of a sudden. I'm kind of at a loss here and I don't know where to begin with diagnostics on it. The only other noticable difference is the injectors seem to be louder than before at or near WOT. I'm a certified gas and small engine mechanic, but my experience with diesel engines is fairly limited. Any help would be appreciated.

In case it helps, the truck has a 4"turbo back exhaust, full air intake and a hypertech programmer installed. The intake was the newest addition, I thought maybe it was an air issue so I made up an intake for it. None of the stages on the programmer seem to make any difference.
 

·
If it aint a CAT itsa DOG
Joined
·
4,553 Posts
Welcome to the ORG. Check your CAC tubes really well. I blew a hole in one and another one slipped below the collar on the turbo spider. I went from 10-11 psi max to 16-17 max, just by fixing the boost leaks. Yours boosts really quick, mine won't hit max boost until 2200 maybe. I might have another leak to find. I also don't have a chip either.
 
1 - 2 of 2 Posts
Top