Ford Powerstroke Diesel Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter #1
the other day after a 2 1/2 hour drive i got onto campus and came to a stop on a hill. i went to go and truck started to stumble and OD light was flashing. i put it in park and put it all the way down in 1st and got it to drive. i let it sit for a bit got back in it and went to the store shifted all normal and no light blinking. drove it back home 2 1/2 hours today and not a problem. i pulled code and got p0720 OSS Sensor circuit malfunction,(truck was runin stock tunes at this time) i cleared that code put in a newer pcm in today and put the dp back in. everything was good until i was at a stop light i gave it a tad bit of gas while i was on the break and the light started blinking again.....pulled code and got P0640 Manifold Intake Air Heater. cleared that code and went for a drive all was good until i got in the driveway.
i did the little break torque again and light started to flash. now i mean little break torque maybe 200 rpm's above idle. i did check code again and it was the 640 code. i also put the truck in nuetral and reved it and set off the OD light? im a bit confused on whats going on. the tranny has 8k miles on it.i left the code on there and went out, i was getting into it and got no light flashing or nothin and everything seems tight?? i am a bit confused on whats going on. im going to check the speed sensor tomorrow but does anyone have any ideas on what could be up??
:dunno:
 
1 - 1 of 1 Posts
Top