Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Just for starters I have used the search function related to this topic, just so no one thinks I haven't attempted to alleviate beginning this thread.
Now, for my problem. I have a 97 OBS F-250 CC 4WD PS Diesel, E4OD trans. Simuntaneously, the ABS light came on and the tranny would not shift into OD. So, I did my research and replaced the speed sensor in the rear end. The first sensor was from Orielly's. The sensor did not turn the light off and the problem persisted, however after a few cycles of driving the OD began to work and the light vanished. Thinking that this may be another faulty sensor, I purchased one from the Ford Dealership. The ABS light went off and OD worked fine. After the first cycle of the switch during my second voyage, the ABS light re-appeared and the tranny would not shift into OD. I've checked the related fuses and all connections. The tranny temps are normal and all other tranny functions are performing properly. Any help would be greatly appreciated as I'm about to pull my hair out. If you have a thought as to what it may be please point me in the right direction.
 

·
Registered
Joined
·
19 Posts
Stick a rag in the gas tank.

Light it.

Run.

Problem solved.

JK, just bumping to the top hoping someone who knows whats going on will read and be able to help. Give me a call tomorrow.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
Taking it to the top. Still having the same problems. When the ABS light is on the trany will not shift int OD. Sometimes the ABS light will go off and tranny shifts fine, however the light doesn't seem to stay of for long. Need some help with this one....
 
1 - 4 of 4 Posts
Top