Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
first time poster, long time lurker for many years.this is now my 4th 7.3. ive got a 95 crew cab that ive been slowly redoing and have had nothing but trouble from this truck. recently i found a good deal on an edge cs monitor and threw this on the truck. i wanted it for more of having digital guages instead of actual pillar gauges. i had a ts 6 position in the past and i removed it when the truck began dying back in the middle of indiana winter. i sold it off and found the icp was getting oil in it and fixed this issue. the truck has had tons done to it just to get it into oem shape. all new steering, all the oil seals on it, all the electrical gremlins sorted out , on and on. only real mods done is 3”dp, intake, hpop crossover, riff raff boots. little things here and there more for optimum performance for a factoryish truck. and recently this edge tuner. keep in mind im not looking for big hp, its more for reliable work truck. take the kids fishin on the weekends old school square body type of thing im going for.

my problems started when i put the edge cs monitor on the tow tune using this monitor. everything was okay. power was greatly improved over stock and then suddenly a hard buck/cut out sensation and then it continued to drive fine. this was under just normal driving conditions. so i made a turn and kinda of leaned on it a little and it bucked much harder, even had some severe injector knock when this occured almost like a spark knock type of noise. but much louder. as the engine warmed to about 200 degrees EOT. i noticed it didnt do it really at all?. put it back on stock tune with edge tuner still plugged in and all is fine, right as the rain. i tried the whole delete and reprogram and it continued to act up until good and hot.
recently replaced items have been icp, cps(tried this the first time it was randomly dying)bowl delete/tightwad mod, both brand new injector harnesses from napa, 8 new glows plus gpr(obviously not related)

tin nut is indeed tight but i do have an alliant power oring kit for the ipr its still original. pressure reading were steady and noticed no drop in hpop pressure during this, or anything out of the ordinary. icp percentage was not abnormally high if i remember it was calling for 16 to 23 percent while driving and was smooth otherwise until it would kick/buck.
truck does have high miles. 310,000miles on original sticks. no issues really out of them. fires right up, runs damn good on a stock tune with the few mods it has to open it up with. restarts up after multiple hour drives. no hard starts or anything.

any thoughts on this folks? i had this same monitor on a 96 back in 17’ and it was flawless. should i try my old cam sensor and see if its interfering with the monitor. i have noticed when hot my idle will be steady then suddenly kick up a little and go back at times. cheapo icp not doing its job? its a amazon special dont flame me lol. should i check fuel pressure stock then switch to tow and see if the mechanical isnt keeping up? im almost to the point to get my new front tank with sump put in. just had so many projects on this thing the parts have piled up. Doing away with the rear tank and just running a front only soon. thinking of doing E Fuel during this time since ive already deleted and using a aftermarket filter head. both tanks currently leak when full, and the old front tank sucks air/fuel mix so i run the rear currently with no issues for about 6 months now. so i know i dont have aerated fuel but am i getting enough?

any ideas fellers? its almost like starting a superduty 7.3 on the 6th tune of a ts switch when its two degrees out and you put the beans to it within 2 seconds of starting it and driving off lol. it bucks hard(my younger days haha) any and all help is very much appreciated
 

·
Registered
Joined
·
3,987 Posts
So it runs fine without the tune? I'd say throw the tunes to the side and get all new custom tunes so you know 100% they are for your set up.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
yeah it runs perfectly normal on the stock tune using the monitor, aswell as deleting the edge files completely and removing the tuner. still drives great. but any other tune wich comes with tow,race, and i think extreme wich i only tried the tow and race. with stock sticks i know it cant get real nasty but i know this tuner worked on my older 2wd 94.5 some years ago. it was stock aswell.

could i run this edge cs monitor for guages only and run a hydra/dp tuner. ive read mixed answers to this. so thats why i finally caved and joined the forum. im sort of stumped at this one
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
UPDATE!!!!!

so ive been working on the rig for a few weeks doing most of the body work when i get time. with work and kids its hard to get time to tackle big projects. Ive been reading about different tuning options and how some tuners interfere with certain crank position sensors. i pondered around all my recent choices in new parts its gotten and it hit me...
back in the winter when i started having issues with the truck randomly stalling of the morning i put a new icp sensor in it and it fixed my issue. (oil in connector) but i also threw in a spare cps at this time. it was off of a 2000 F550 bucket truck we have at work that was wrecked. truck ran no different when i put this in at the time other than the sensor looked like it was a replacement on the bucket truck.
Fast forward to today when i remembered reading some switch style tuner does not like certain crank sensors wich i believe it was dp-tuners tunes that was quoted to not like certain sensors. this was a gray sensor out of the 2000. i put my old one in. reprogrammed the edge tuner back to the tow tune and ill be damned if it quit its random bucking under load and runs perfectly fine now on my original black sensor. i could run the edge on stock tune using display on the superduty cps but would not tolerate any sort of tuning with the gray sensor.

just wanted to share this bit of info ive found and hope this helps people when issues arise when using a tuner of some sort and using frankenstein parts lol
 
1 - 4 of 4 Posts
Top