Ford Powerstroke Diesel Forum banner

21 - 34 of 34 Posts

·
Registered
Joined
·
48 Posts
I will have to find a good working one and test it first to see if it works if it doesn't anything else you can think of
[/QUOT
Fuel pressure.....make sure you have fuel in the top fuel bowl...bubble test.....ficm wiring harness connections...the obvious stuff like battery volatge...also make sure your cranking sound is nice and even..no cank,crank,,,whine..crank..crank whine..should be nice and steady...can you see your ficm logic power by chance???
 

·
Registered
Joined
·
1,424 Posts
Double check the plugs in the ficm, particularly the one most forward on the ficm... Maybe unplug and replug it in, making sure it "snaps" into place.
Then check fuel, take the upper bowl cap off and see if there's fuel, if there is, do the bubble test. Make sure the map port is clean and the hose is in good shape. If everything checks out, unplug the Ebp sensor.
The things that cause no/low boost are map, Ebp sensor or cac system.

Sent from my Redmi Note 9 Pro using Tapatalk
 

·
Registered
Joined
·
1,424 Posts
I did unplug and plug back in no difference I will check the map port and hose thank you
Leave it unplugged, it'll throw a code, but rule out the Ebp sensor /sensor tube, or verify it's bad.
The truck will need to be able to start before this matters.

Sent from my Redmi Note 9 Pro using Tapatalk
 

·
Registered
Joined
·
48 Posts
Check your battery voltage too...ficm doesn't like low battery voltage....plus it's cold out...ficms dont like the cold either...lol
 

·
Registered
Joined
·
20 Posts
You mentioned no boost all day and black smoke. Have you checked the charge air cooler boots and related piping. Also the charge air cooler itself. A large leak would create no boost. Hope this helps.
 
21 - 34 of 34 Posts
Top