Ford Powerstroke Diesel Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Looking for help I have an 06 ford f350 super cab long bed stock the last week it has started really rough and would not start without a little help well today it fired up nice and was running great let it warm up for half an hour to an hour and took off down the road got about 2 miles down the road and it started blowing black smoke even at idle it was smoking came to a stop sign turned Trans shifted from 1st gear to second and then the whole truck shut down without any warning now all it will do is crank over does not try to fire or anything......any help would be greatly appreciated
 

·
Registered
Joined
·
48 Posts
Looking for help I have an 06 ford f350 super cab long bed stock the last week it has started really rough and would not start without a little help well today it fired up nice and was running great let it warm up for half an hour to an hour and took off down the road got about 2 miles down the road and it started blowing black smoke even at idle it was smoking came to a stop sign turned Trans shifted from 1st gear to second and then the whole truck shut down without any warning now all it will do is crank over does not try to fire or anything......any help would be greatly appreciated
DO you have any kind of scan tool??...Like tourqe App? ..so you can get some numbers??...FICIM Voltage...Icp voltage...etc..I think black smoke is fuel...
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
Yes have a scan tool all voltages on the ficm read good and icp also won't start even with a little snort of ether and I thought white smoke was fuel??
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
Yes has around 520 psi when cranking unplugged the icp sensor and tried to start still nothing I unplugged the ebp sensor tried to start and nothing doesn't even try to fire just cranks
 

·
Registered
Joined
·
48 Posts
Yes has around 520 psi when cranking unplugged the icp sensor and tried to start still nothing I unplugged the ebp sensor tried to start and nothing doesn't even try to fire just cranks
thats good...your getting oil pressure....so it has to be fuel related or electrical....
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
Also I had no boost yesterday at all according to the gauge and I have also heard of people say there ficm reads good on a scan tool but can still be bad
 

·
Registered
Joined
·
24 Posts
Discussion Starter #15
Yes on my scan tools says it is synced is there any other way to test the ficm besides a scan tool or does it have to go to ford
 

·
Registered
Joined
·
48 Posts
Yes on my scan tools says it is synced is there any other way to test the ficm besides a scan tool or does it have to go to ford
you can test it with a multimeter on the inside but you have to be careful ...or you can swap it out with a known good one...in this case a trucks that runs..and see if it works
 

·
Registered
Joined
·
24 Posts
Discussion Starter #18
I was told if I bought a ficm I would have to take it to the dealer to have it programmed you can but one already programmed??
 

·
Registered
Joined
·
24 Posts
Discussion Starter #20
I will have to find a good working one and test it first to see if it works if it doesn't anything else you can think of
 
1 - 20 of 34 Posts
Top