Ford Powerstroke Diesel Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter · #1 ·
Is my PCM gone? Don't know if any of you have kep up with my most recent problem. But I got it posted in this section as well.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #6 ·
IM getting a wait to start light, replaced CPS going to try it in the morning.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #7 ·
Finally got enough juice to try to crank the truck. Hooked up mu cheap super chips scanner and got p0344 and p1661. I did just replace the CPS but whose to say the new one isnt bad and my old ones good.

What would trip a 1661 code? The truck has been having a rough idle on a cold start, and I mean rough before it died it would sound like a miss then slowly die on its own. It would take about 20 cranks to get it running again. IF I plugged the truck in over night, I get none of these problems.

Now the trucks sitting dead in my driveway, yet I have it up for sale with people wanting to buy it lol.
 

·
BANNED by Kris
Joined
·
6,322 Posts
Output Circuit Check is low. Hopefully it's the weak batteries. With the key in the "run" position pull the connector off the MAP sensor. Using a DVOM see if one of the female pins is suppling 5v reference.

-Yes? Reconnect and move to the EBPS and do the same thing.

-No? Check all under hood fuses and test again. Still no? Possible popped PCM.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #9 ·
Update on truck, still won't start.

No smoke out exhaust
Tach bounces when cranking
Wait to start light comes on like normal.
Cranks great with good voltage.

Got a buddy with a spare IDM and PCM, but I am leaning towards the IDM since my rpm and everything else is working.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #10 ·
update, swapped a good idm/pcm into the truck still no start.
 

·
Registered
Joined
·
1,189 Posts
I'm subscribed to this. I'm having the same problems. Checked fuel pressure hpop uvch and everything checks out. Has a cps code and no tach moving. New CPs and the tach moves but still no start


Sent from my iPhone using Autoguide.com App
 

·
BANNED by Kris
Joined
·
6,322 Posts
Pull the ICP connector. Looking into the connector (with the retention clip on top) the top left pin should have 5v with the key in run. Does it?
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #13 ·
Pull the ICP connector. Looking into the connector (with the retention clip on top) the top left pin should have 5v with the key in run. Does it?
I pulled it yesterday and cranked it and it threw a ICP code, plugged it back in and cranked it. Code went away, led me to believe it was good. I can't find my damn meter to check voltage:doh:
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #14 ·
What about the IPR is it out of question?
 

·
BANNED by Kris
Joined
·
6,322 Posts
No but without a meter it's hard to tell whether its a problem or not.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #16 ·
Watching a couple other threads, still no update. Still sitting dead in the driveway. Swapped pcm and IDM for a known good one and nothing. Tach will bounce when cranking but still no start....

Had a buddy bring a nice scanner over but said he couldnt get much of anything to come up except a keep alive memory code. I tried hooking my superchips scanner up to the OBD2 port but it wouldn't even connect now, never had a problem before.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #17 ·
Finally found my meter, so hopefully i can narrow things down now. Thanks for all the help big fuel, where should I even begin now.
 

·
BANNED by Kris
Joined
·
6,322 Posts
Here are all of the meter readings you should be seeing with the volt meter. Back probe the connectors, don't scrape or puncture the shielding. That creates a permeant resistance in the line. Don't forget that clicking the yellow bar gives you a better image. Right click and paste in word. Then print and take to your truck for testing. Happy thanksgiving.




 

·
Registered
Joined
·
167 Posts
Discussion Starter · #19 ·
Thank you sir, I will be doing this saturday morning.
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #20 ·
ICP turned out to be good, hooked up my cheap scanner to run gauges and got

0603
1661
1280
0472
 
1 - 20 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top