Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
Hey guys I posted a while back in here about my 06 f350 that won't start. I bought the truck A little over a year ago with an sct x3. No problems tune wise or starting. In March I had catastrophic failure associated with the egr cooler blowing.

There was tons of coolant in the oil so I ended up getting a new longblock, complete with injectors and associated sensors arps and egr delete. New motor should be 100% perfect forever now with just regular maintenance right?

Now fast forward to last week of June, one morning the truck cranks a loonnngg time and fires. So I was nervous but it didn't happen again, until 2 weeks later it just woudn't start. And would crank and crank with no attempt to fire. I returned it to stock, no difference. I had it towed to the guy who put in the motor, he said the truck had lost sync between the ficm and pcm. And he had it running pretty quickly.

He blamed my tuner and said it was the wrong one but he could sell me a new sct with canned tunes for $525. I said no, its the same as the one I have. I put the street tune back on the truck and it worked perfect just like before. Now last night it cranked a long time and got me worried, sure enough this morning it doesn't start.

I'm not going back to the same guy, for various reasons he's lost all my trust. 2 hitches disappearing from my tool box, my tuner wasn't in the truck when I picked it up cause he "took it home to research" and his quote was out 3 grand.

So anyways what would cause it to lose sync like this? It seems wierd it would load the tune fine, run fine then out of nowhere die and not start. I was on hold with sct at the end of the day for an hour but didn't get through before they closed. When it runs its flawless, there's no codes at all.
 

·
Registered
Joined
·
4,222 Posts
Hope someone who knows tuners will repond too your problem. I try to stay away from posts involveing tuners I just do not know enough about em and how they work.

So here is a bump for ya
 

·
Registered
Joined
·
169 Posts
Discussion Starter #3
I haven't been able to find any other posts that would indicate the tuner. My other thought is the immobilizer I was forced to install has a questionable splice into a key wire. And on that a potential chafed wire.


Sent from my Autoguide iPhone app
 
1 - 3 of 3 Posts
Top