Ford Powerstroke Diesel Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
My 06.5 f350 6.0 has had an eletronic problem for about 2weeks this problem just happened out of no where i had no symptons before. I had a couple bulbs on the back of instrument cluster that were bad so i changed them and drove it to and from work then I let the ole lady drive it and then everything just went out and ive checked all the fuses and #41 is not getting any power but is not blown and all electronics are stock, I have no radio but the lights and clock, and itll let me eject the cd, the door ajar and reading lights dont work, the windows dont work but the door locks do, the auto headlights do not work either, but when you manually turn them on the headlights work and the entire dash lights up like it should even the radio, None of the gauges turn on move or anything when the key is turned on or truck is running, the odometer isnt working the only lights that show up on the instrument pannel is the battery, air bag light, the turn signals and high beams. also the wipers do work dont know if this makes a difference
 

·
Suck, Squish, Bang, Blow!
Joined
·
6,471 Posts
Sounds like you had a main fuse blow. Check the fuses and relays under the hood. Might have had a main ground wire come off somewhere as well. Good Luck.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
I've swapped relays and checked all the the fuses up on the driver side fender and all are good are there any inline fuses that are not on the box and where are the grounds that tend to be a major problem.... and the gem is that the same as the body module and what about the instrument cluster do you believe any of these went out or unlikley since they are getting some power
 

·
Registered
Joined
·
12 Posts
How bright are the headlights when you turn them on. I just had basically the same thing happen to me , same symptoms, and I think it is my alternator as I just installed new batteries three days ago and now they're dead.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #6
I will recheck again i took and tested all for continuity but will check again i could have missed one if you think of the fuse number that where bad let me know... and the lights seem to be bright enough the batteries where charging at like 13.4 and the batteries where just replaced a month ago
 

·
Registered
Joined
·
2 Posts
Hey, love to know what you find. This same exact thing happened to me this morning when I was getting on the to make a 6 hour drive home. UGG!
 

·
Registered
Joined
·
1,509 Posts
I also have a very similar problem. I cut the wires to my under hood light to splice in an LED light strip. When I got back in the truck I started it and my radio wouldn't come on. Then I tried to open the windows and non of them work. Its a very strange problem because I am getting main power to the radio because the dash lights on the radio all come on when I turn on the headlights and the time shows and the ford logo comes up when I press the power button (I have factory nav). On the driver window switch I'm not getting any power because the switch does not illuminate when I turn the headlights on but the door locks work and the power mirror works, but none of the backlights are on? I haven't really had a change to check for power or check any fuses but I'll give updates if I find anything.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #10
It ended up being my cluster that was bad bought one off ebay for $42 and installed it the odometer is registered in the cluster... but on the bad news now nothing turns off when i open the door so everything stays on till the 10min relay turns off so that means i have door ajar problem now i have to track down.. any help with this would be greatly appreciated
 

·
Registered
Joined
·
102 Posts
I have the exact same problem with my 06! Just happened with no warnings. No radio, gauges or windows. Worst part is the windows were down and now its raining. Checked all fuzes and none are blown. HELP!!
 

·
Registered
Joined
·
2 Posts
Still haven't been able to solve mine. It started right after I had to jump start it. Related??? Just found out Im deploying in 5 days, this problem may have to way 7 months. Sorry Honey!! lol
 

·
Air Assault!!
Joined
·
716 Posts
I have an issue when i get in the truck in the AM to head to work. I start the truck and probably once a week the radio doesn't turn on and the windows will not roll down. AC works so does Headlights and guages. I think it has to do something with the RAP relay. RAP (Retained Accessory Power). Its what keeps the power on until the doors open. I'm gonna check the factory service manual to see what it all runs through and go from there.
 

·
Registered
Joined
·
222 Posts
I have the same problem tony


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
1,509 Posts
We need to get to the bottom of this. Can we please have some techs chime in or something. So many guys are having similar issues and it seems it's something other than fuses or relays :dunno: I'll be taking my truck to the dealer next week if I get get it working right.
Help us figure this out.


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
43 Posts
I am having a similar problem, but with a twist to it. Have a 2006 F250 by the way. Anyway, driving down the freeway and lost the radio, all gauges, power windows. When I started to get off the freeway and started braking, everything started working again. It kept doing this driving on surface streets for a while too. Lose power, but would come back on when braking. Had the batteries checked and were good as well as the alt (13.25V). This was friday afternoon, went to start it this morning and the batteries were dead. Remote lock wouldnt even work.

Any ideas?
 

·
Registered
Joined
·
102 Posts
Anyone figure this out? I sent my cluster out for repair. Got it back and the gauges worked but not the radio or windows ect. Now everything is dead. Sitting in driveway with dead batts after testing out fine a few days before.
 

·
Air Assault!!
Joined
·
716 Posts
From looking at the schematics.... before the power gets to the radio is goes into the central junction box (fuse box under the dash) and the relay that is in charge of the RAP is relay 2075 (middle row on the bottom) with key on it when removed it should not allow the radio to power up or windows to work.

Try replacing it and seeing if that works.

The signal sent to turn that relay on comes from the cluster. Since i have none of the other symptoms and i hear a click right before everything turns back on i would bet that it is a relay. I haven't had the issue in a few weeks so i haven't bothered to replace the relay just yet.

Also check to make sure fuses 2, 41 and 42 are good. These are also found under the drivers dash.
 
F

·
Guest
Joined
·
0 Posts
Mr

I have a 2005 f-250 that started to have intermittent loss of all dash gauges, the radio, and power windows. radio had power and would eject the cd, but not play. it was very rare and would mostly happen when raining. It became worse and then was constant, but would go away when it rained now. then it began to overheat and would shut down, Had to replace the batteries, and it worked for about two weeks. now it is parked in fear of further damage. I have had a computer hooked up but no major codes. I am a disabled vet, raising three kids alone and no job. I really need help. This truck is our life and vital to our survival at this point. I just don't have the money to put it in the shop and need some advise of what it may be.
 
1 - 20 of 22 Posts
Top