Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
517 Posts
Discussion Starter #1
I had 14 psi at the FPR so I installed a brand new fuel filter housing complete with new FPR, drain valve, vacuum switch. (the whole unit came with everything including fittings) I installed a new gauge at the shraeder valve (3rd one) and I got 12 psi at idle and took it for a 15 mile spin and the gauge read 5 psi. no leaks, no fuel in valley. This truck runs good, idles good, Kind of feels slugish when you get on it like passing someone. I drained the fuel bowl housing, not a drop of fuel in it or the filter and started it, it turned about one and a half turns and started. I don`t see how that could be a bad fuel pump but can`t understand why there is only 5 to 10 psi pressure at the FPR. Somethings wrong and I have a trip to make and would like to find it here instead of on the road. Any sugestions appreciated TIA
 

·
Registered
Joined
·
353 Posts
Is the spring/"thimble" installed under the 19mm plug on the FPR?

Why don't you think its the fuel pump?? How old/how many miles on the pump?
 

·
Registered
Joined
·
517 Posts
Discussion Starter #3
Is the spring/"thimble" installed under the 19mm plug on the FPR?

Why don't you think its the fuel pump?? How old/how many miles on the pump?
Thanks for the reply. Yes the spring is there with a bb mod. The reason I`m thinking it isn`t the FP is because of the way it filled the bowl with fuel so quickly after I drained it completely empty. Don`t know about the miles on pump, truck has 146,000.
 

·
Registered
Joined
·
353 Posts
Dont let the fact that the fuel bowl filled up fool you...If had SOME pressure so I can see why it would fill...Sounds like you are planning on pump replacement by your other thread which is what I would do.
 

·
Registered
Joined
·
517 Posts
Discussion Starter #5
Thanks, I believe you are right, it had "some" pressure and thats why it filled, Can`t find any other reason for it, looks like I need a pump.
 

·
Registered
Joined
·
517 Posts
Discussion Starter #6
Thank you guys Got-er done (with your help).
 

·
Registered
Joined
·
353 Posts
everything workin? Pressure back to normal?
 

·
Registered
Joined
·
517 Posts
Discussion Starter #8
everything workin? Pressure back to normal?
Everythings good. Started it up, pressure rose to 50psi. Went for a short spin was sitting on 42 at idle when I got back. Thats without the bb mod. Thanks for the help.
 

·
Registered
Joined
·
353 Posts
GREAT! Very glad to hear all has worked out! :woot:

:thumb:

-Casey
 

·
International Threat
Joined
·
13,087 Posts
I was going to say replace the fuel pump but it looks like you've already done that!

Just FYI - having fuel pressure that low can HURT your injectors big time! Anything below 35psi is bad!
 

·
Registered
Joined
·
517 Posts
Discussion Starter #11
I was going to say replace the fuel pump but it looks like you've already done that!

Just FYI - having fuel pressure that low can HURT your injectors big time! Anything below 35psi is bad!
Thanks. I will remember that. Had the injector o-rings replaced awhile back. Don`t know if the FP was responsible. I had 50psi at idle after the FP install, took it for test drive had 42psi after it warmed up. Sure beats 5psi. Thanks for the info.
 
1 - 11 of 11 Posts
Top