Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
1995 F350 7.3 E40D 2WD...My cruise stopped working so I was on here looking for recommendations, a lot of postings said check the easy stuff...lights, fuses, emergency brake horn etc. My brake light over the rear window was out...I replaced it and still no cruise...then I noticed my reverse lights don't work either....think its a coincidence beyond my sound mechanical skills? hah ha.

All of my under dash and distribution box fuses are good, my horn DOES work so the switch in the steering wheel is ok..maybe?, all of my lights work EXCEPT my reverse lights. My transmission shifts fine so I am doubting the speed sensor on the transmission but I notice there are switches on the trans for both of my pains.

For the record...yes I was into the tranny a few months ago, all was well since then I thought....I notice the speed sensor on the tranny controls the cruise, and the backup light switch is also on the tranny...beyond testing them in the morning I am out of ideas.

So...beyond me getting my nasty grubs all of the trans (again)....any one know if these are related....?

Thanks.
Matt
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
Problem is fixed. The backup light switch on the transmission (neutral safety switch as I am used to knowing it) had a short in it and would blow fuse #5 in my power distribution box. Once the switch and fuse were replaced my reverse lights and my cruise started working again.

Hope that helps someone else someday.
 
1 - 3 of 3 Posts
Top