Ford Powerstroke Diesel Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
to start with this forum has helped me with problems for at least 5 years on my trucks.yal are awesome! up til now all my problems have been resolved reading other posts.now i have a mystery that even 2 certified shops in my area cant figure out.i have a 1997 f250HD 4x4 7.3, it shut off abruptly and the chase for problem started. here is all that has been done as of today.
1- new cps (black not grey)
2- new ipr valve and sensor (riffraff diesel)
3- known good hpop from another running truck of mine
4- new injector o rings (riffraff diesel)
5- new valve cover harness both sides (ford dealership)
6- new icp (riffraff diesel) plus checked out on another running truck as backup
7- new fuel bowl (riffraff diesel) and harness
8- new engine wiring harness (riffraff diesel)
9- removed chip on pcm when started this long road
10- new map sensor
truck has rebuilt IDM on it. will start and run perfectly for 5 min then shuts off.after long start it will run 2 min then shut off,then wont start again until it sets for a hour or so. i installed a known good idm from another truck i had and passenger side bank injectors dont fire but the truck will fire up and idle all day every time without stalling. wts light works as well as all others on dash when cranking and running. no cell light.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
yes hpop is full and fuel bowl doesnt lose any pressure on gauge. i havent pulled lid on fuel bowl and physically checked though,just watched gauge. lol im good with any questions cause this riddle is killin me. i do have a friend coming by later today so i can put both of my idm on his truck to double check them to make sure they work as should.
 

·
Premium Member
Joined
·
4,323 Posts
Yeah that will be a big help double checking those.

Next time it dies check the fuel bowl and make sure there's fuel in it.

If fuel bowl and HPOP are full then we can rule out starvation from those.

A scanner with live data will really help. I know you got a new fuel bowl but disconnect the fuel heater on the side of the bowl and leave it protected.

Doing a buzz test before starting it and after it dies will be beneficial too.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
we tried idm on another truck and no problems it worked perfectly. i did a buzz test today and all tested good no differences in sound. went ahead and changed fuel pump out and fired it up. i have valve covers off and watched all the scoops oiling pretty good.it ran for 20 min this time and when it quit i checked both the fuel bowl and hpop res and both were good on levels. still no cell or codes stored in pcm.ipr runs at at 15% and changes as it should when throttled. icp sets around 650 psi at idle steady and when throttled will climb as it should. i also swapped tanks by switch just to check if sock was plugged and it was same on other tank.i figure the odds of both stopping up at same time was slim.it seems that when oil temp hits around 140-150 is the shuttoff zone every time. i have had 5 of these trucks and love them to death but this one is going to kill my a#&!!! lol
 

·
Premium Member
Joined
·
4,323 Posts
After it died did you immediately try to restart it?

@Patrick Feeley need a second opinion here.

At 140F it shouldn't be making any fueling changes or anything of the sort.

Whats your voltage output on the alternator stud? I wonder if there is an internal short when it gets warm. Or maybe a relay is getting heat sensitive.

I know IPR will get heat sensitive over time but usually results in erratic idle or laziness.
 

·
Registered
Joined
·
3,308 Posts
Wow! That's a tough nut to crack. EOT sensor going wonky when hot? What are the data reading if you immediately try to restart? Cheers!
 
  • Like
Reactions: White95f250

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
it wont start immediately when it dies. wait 15 min and it will start back up but only run for 30 seconds or so then dies. i installed a new EOT sensor from ford as well with no difference.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #14 ·
i did notice yesterday that oil was leaking through a few of my glowplugs into top of head.will this cause some of my problems with dying?? i have some ordered and will be here this week
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #16 ·
there seems to be oil leaking up through glow plugs through top into the electrical connection. I tried tightening them up some. 2 quit leaking but 3 didnt.
 
1 - 17 of 17 Posts
Top