Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
I know im probably jumping into conclusion to soon but just here me out. I replaced the oil seal, dust seal, rotors , calipers, pads and ball joints in the front end on both sides. In the rear i replaced all the bearings in the hub, new seals, e brake, rotors, calipers, and pads both sides...here are my problems

1. Brakes are spongy and wine with the power steering. Took it for a 2 mile ride and the back brakes were red hot and smoking. I'm going to to a ATF flush tonight and hopefully that solves the wining problem. I believe there is still air in the lines since its spongy still but could air really cause the calipers to not release properly? everything is brand new in the brake department. I took the tires off to inspect and the calipers were tough to take off the rotors.

2. On the test drive i couldn't keep the front end straight and it just felt light and floaty. Ive read everywhere on proper torquing of the ball joints and you can ruin them if not done right but i cant find any solid info. I bought TRW Spicers from NAPA and i torqued the bottom to 40ft lb then the top to 69ft lbs and the bottom to 150ft lbs. The ball joints didn't come with any torque specs and i found those specs from a Moog form. I'm hope i didn't ruin the ball joints but im thinking that the new ball joints un masked a world of other front end issues. Im going to jack it up and get under it tonight while someone plays with the steering to see if its tie rods or anything else. Right off the bat the steering wheel has a lot of play and is no longer centered when going straight. I dont think there could be a break in period for ball joints. oh and the truck needs an alignment bad. I just mounted 285/75/16 Coopers on it and i know it hasn't been aligned since the guy before me bought it in 2000. But can an alignment really fix the wondering issue?

Just looking for some other things to check. Just tell me it going to be all right!!
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
went through the truck tonight. Re bled all the brakes to get good clean fluid. Flushed powersteering fluid. Brake pedal came back firm so i thought i fixed it. After i took it for a testdrive after about 3 miles all the brakes started closing up. It took all i had to overpower the brakes and get home. Oce i made it back everything was hot and smoking. all 4 corners. It was breakig fine up until then and once it started it just got worse.
 
1 - 2 of 2 Posts
Top