Ford Powerstroke Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1 (Edited)
so my 97 f250 7.3/zf5 just made the 6 hour journey to wyoming. ran like a champ all the way here. now when i leave a stoplight or give her a little gas, theres a kind of hissing noise that i hear coming from the engine bay, it does not get louder/faster with more RPMs, but if it rev it and let off it quits, ideas?

and YES i know what a turbo sounds like! haha
 

·
Registered
Joined
·
996 Posts
Only things I'm coming up with is a boost leak or air intake leak. Is your air filter getting clogged?
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
Only things I'm coming up with is a boost leak or air intake leak. Is your air filter getting clogged?
my air filter is clean but i was just thinking of that, boost leak being on the y-pipe that goes to each valley and intake leak being the boots pre-turbo correct?
 

·
Registered
Joined
·
996 Posts
Yep. That's what I was thinking.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #5
Yep. That's what I was thinking.
you were correct!, the orange boot that connects the turbo to the cast tube has a tear, after calling around the only place that carries it is fors, i think ill just rip it all out and go AFE. does that sound like a good excuse? :D
 

·
Registered
Joined
·
996 Posts
Sounds like a good excuse to add an intercooler.;)
 

·
Registered
Joined
·
46 Posts
Discussion Starter #7
Sounds like a good excuse to add an intercooler.;)
that sounds even better BUT being a broke azz college kid, the afe is a little more reasonable:)
 

·
BANNED by Kris
Joined
·
6,317 Posts
RiffRaff has your boots for $20....more money for beer, ah , I mean books.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #9
ok new issue!, put on my AFE this morning, still made the hissing noise, i realized that my oil was about 3k miles old and was just ran 2000-2500 rpm for 6 hours straight, i just did an oil change and the noise seemed to stop, but i noticed that my truck is taking longer to crank now and upon starting it fires then a second time and smoothes to idle. also, i gassed it to turn around in some dirt and when i let off the gas pedal the rmps went way down, almost to dieng, then it caught itself and ran fine. hpop? icp? any ideas? seeing as the OBS uses a heui system thats what i could come up with
 

·
Registered
Joined
·
996 Posts
What oil did you use? 3000 miles shouldn't be bad on these if you are using the correct oil.

An ICP problem is easy to troubleshoot. Just un-plug the ICP and drive it for a while to see if the problem goes away. Normally, an ICP loses it's seal first. There will be some oil in the plug, or a leak where the ICP goes into the head.

If you have an HPOP problem, there will likely be a HUGE oil leak.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #11
im thinkin my power steering pump is losing a bearing or something because it hisses when i have the wheel turned and quits when my wheels are straight
 

·
BANNED by Kris
Joined
·
6,317 Posts
Hisses or squeals? Only hard over or just with some light pressure?
 

·
Registered
Joined
·
46 Posts
Discussion Starter #13
Hisses or squeals? Only hard over or just with some light pressure?
its a hissing noise, i look at the pump and there looks to be some fluid coming out around the shaft the pulley is on
 

·
BANNED by Kris
Joined
·
6,317 Posts
Sorry, the notification system isn't working for me. I didn't realize that you had responded. Power steering pump can be rebuilt cheaper the replacing but if the leak is at the bearing then you are better of just replacing. Be sure that the hiss is not a dry/cracked rubber line off the vacuum pump just below the power steering pump.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #15
Sorry, the notification system isn't working for me. I didn't realize that you had responded. Power steering pump can be rebuilt cheaper the replacing but if the leak is at the bearing then you are better of just replacing. Be sure that the hiss is not a dry/cracked rubber line off the vacuum pump just below the power steering pump.

fixed! heres the story,

i had to put an alternator, and when i did i noticed some metal shavings around the vacuum pump, i thought well ill fix it monday, i proceeded to the ranch, and at 4 sunday morning i started it up and could head a clicking noise, like a bearing race that was shot, so i was headed home and started to smell rubber burning, next i know the batterey light is on, no power steering no brakes, so i pulled over, turns out the vac pump seized and smoked my belt, i cut her off and luckily was only a mile out of the next town, i parked at the fuel station and got a ride to work, that night she took a ride on the back of a cummins :doh: and got fixed today, good as new!
 

·
BANNED by Kris
Joined
·
6,317 Posts
Nice, thanks for the update.
 
1 - 16 of 16 Posts
Top