Ford Powerstroke Diesel Forum banner

1 - 20 of 42 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1

·
Registered
Joined
·
8 Posts
halfway sounds like a lifter... have you ever had the IPR out to clean the screen? were you having any issues before you replaced the injectors?


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
146 Posts
Discussion Starter #3
No the truck never had any issues like this before the injector change, It started today on the second start of the day and it cleared right up now I just went out to start it again and thats when it knocked like that. Was just running rough earlier but never a knock
 

·
Registered
Joined
·
146 Posts
Discussion Starter #4 (Edited)
Does this sound like a bad injector? You can really feel the motor stumble when it starts to knock
 

·
Registered
Joined
·
8 Posts
if you have access to a scan tool, check and see if you have any codes. have you ever replaced the egr or oil coolers? what about the IPR?


Sent from my iPhone using Autoguide

'03 Ford F350 6.0L Powerstroke
Bulletproof EGR cooler, High Idle Mod
 

·
Registered
Joined
·
146 Posts
Discussion Starter #6
I have the CTS which threw a code for the #8 cylinder when I replaced the injectors last week. I deleted the EGR and changed the oil cooler 5k miles ago. I havent done anything with the IPR
 

·
Registered
Joined
·
8 Posts
Im assuming when you changed the oil cooler you changed the screen in the oil cooler sump correct? Injector 8 code before or after you replaced the injector that was bad when you got the new set?


Sent from my iPhone using Autoguide

'03 Ford F350 6.0L Powerstroke
Bulletproof EGR cooler, High Idle Mod
 

·
Registered
Joined
·
146 Posts
Discussion Starter #8
Im assuming when you changed the oil cooler you changed the screen in the oil cooler sump correct? Injector 8 code before or after you replaced the injector that was bad when you got the new set?


Sent from my iPhone using Autoguide

'03 Ford F350 6.0L Powerstroke
Bulletproof EGR cooler, High Idle Mod
Yes I changed the screen when the new cooler was put in. I got the Injector 8 code after I put the new set of injectors in the first time. So Jesse sent me a replacement and I put it in this week. Truck ran good for few days and this happened yesterday. The truck isn't throwing any codes for this one,ICP is good. FICM shows 48V at all times and the fuel pressure is 64.5 PSI.Is it possible I just have another bad injector? The Knock is what makes me sick to my stomach
 

·
Registered
Joined
·
146 Posts
Discussion Starter #9
Bump, has anyone ever heard a knock like this that was an injector? Just really worried about this. Don't want to pull it apart before I get confirmation. Can't talk to Jesse untill tomorrow


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
146 Posts
Discussion Starter #10
Ok so I started the truck again this morning, the knock is constant now and the truck started puking white smoke pretty good and it threw a code for #4 injector now. It has to be the injector right? I pulled it in the garage and pulled it all apart and pulled the #4 injector and it looked good. The 2 nuts were tight and couldn't see any blow by


Sent from my Autoguide iPhone app
 

·
Premium Member
Joined
·
5,700 Posts
the knock is likely fuel knock. It could be from a faulty injector or a loose injector hold down. another thing to look for is possible copper washers got double stacked somehow.

its tough to say which hole is causing it. you're going to want to look for cylinder contribution codes first, but since you say #4 is throwing a code that's probably the offending injector
 

·
Registered
Joined
·
146 Posts
Discussion Starter #12
the knock is likely fuel knock. It could be from a faulty injector or a loose injector hold down. another thing to look for is possible copper washers got double stacked somehow.

its tough to say which hole is causing it. you're going to want to look for cylinder contribution codes first, but since you say #4 is throwing a code that's probably the offending injector
Thank You, It finally threw the #4 code today when I was pulling it in the garage. I did check for copper washers on Install of the injectors and there were none in the holes, I also cleaned and blew all the oil out before installing the new ones. Im going to see what Jesse says tomorrow not sure why they are all failing. I'm thinking of ordering a new injector harness and sending my FICM out just to be sure,It reads good:dunno:

Thanks again for all the help
 

·
Sinister Diesel Sucks!!!
Joined
·
2,498 Posts
I lost one injector back in January, found a whole set here through the Org w/ no core, I was dealing w/ stiction issues anyway, so I replaced all off them. Was thinking about sending my original set to Warren for the stock+ treatment. Which ones did you go with? You are the first person Ive seen thats used him, kinda scary to think you got a bad one out of the bunch. Any idea of what gives?
 

·
Registered
Joined
·
146 Posts
Discussion Starter #14
I lost one injector back in January, found a whole set here through the Org w/ no core, I was dealing w/ stiction issues anyway, so I replaced all off them. Was thinking about sending my original set to Warren for the stock+ treatment. Which ones did you go with? You are the first person Ive seen thats used him, kinda scary to think you got a bad one out of the bunch. Any idea of what gives?
I went with the 155+ stocks . I am expecting the replacement injector and some new copper washers tomorrow to hopefully get her back going again. I have read a lot of great reviews on Jesse at Warren and I have to say he is a stand up guy who is great to work with.
 

·
Registered
Joined
·
146 Posts
Discussion Starter #16
whats your fuel pressure? could be low pressure issues
65 psi drops to 60-61 at 3/4 throttle, I don't think that's the problem. I sent my FICM out to get looked at even though it read 48v and I'm getting new batteries. I really just want the truck to be reliable again. Its been down almost a month now. Thanks for the suggestion
 

·
Premium Member
Joined
·
5,700 Posts
I hate to jinx myself but I've never gotten a bad reman injector from ford. Honestly you couldn't pay me to put in an aftermarket injector.

considering I'm doing all 8 in an ambulance right now hopefully that first statement remains true
 

·
Compression Ignition Addict
Joined
·
7,130 Posts
I hate to jinx myself but I've never gotten a bad reman injector from ford. Honestly you couldn't pay me to put in an aftermarket injector.

considering I'm doing all 8 in an ambulance right now hopefully that first statement remains true
+1 (except I would trust Casserly's injectors but that is it)
 

·
Registered
Joined
·
146 Posts
Discussion Starter #19
This is a lesson I'm learning the hard way:(
 

·
Registered
Joined
·
146 Posts
Discussion Starter #20
The saga continues:( I replaced the injector with the contrbution code, As I was starting the truck I could hear it was still hydro locked,It fired off and knocked and smoked just like before so I shut it down and pulled the other side apart,Truck also threw a code for the #3 cylinder contribution now. I really dont understand why I am having such terrible luck with this. I pulled the Passenger side apart and the #5 and #7 injectors were a bit dirty and smelled very strongly of diesel while #1 and #3 didnt smell at all and were clean.

What could be causing this? The O-Rings all look fine,I checked the torque before I pulled them off and it was still right on. No double stacked copper washers etc..
 
1 - 20 of 42 Posts
Top