Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
647 Posts
Discussion Starter #1
Hey guys, my truck has always started with just a touch of the key from the day i bought it till just the other day.


two days ago I hit the key, and let off it in instinct, the truck didnt start, it took a extra 2 second crank to get her fired up, it made me angry and confused me but I didnt think to much of it, it ran fine the rest of day even after sitting 5 hours at work.

This morning I went out to start her up and it didnt start right up, it took me 4 tries @ 2-3 second cranks to get her to kick, once she fired she smooth right out and seemed to run fine, no start problems after that.

Not looking to forward to see how she starts tomorrow, but It seemed that my battery was being drawn down a normal amount by the glow plugs, but it was 60 degrees out. I will also mention that there was plenty of white smoke out the tail pipe, that makes me think im getting fuel, so wouldnt that mean Im getting hpo? what could the problem be? im confused.

I havn't looked into at all yet, Im just posting in advance for ideas and support, ill check my fuel filter tomorrow, very recent oil change, Ill check oil aswell tomorrow morning, oil pressure seemed fine. no check engine but im not sure if my check engine light bulb even works.

any help is awesome, thanks everyone! hope my first problem is not a big one.
 

·
BANNED by Kris
Joined
·
6,317 Posts
Rash of plugged FPR screens this week check yours. Might as well (though if the GPR is working not likely) check fuss 22 in the engine bay as well (middle row, farthest from you).
 

·
Registered
Joined
·
647 Posts
Discussion Starter #3
Sorry for the slow reply guys, but I think it was a gpr, I started noticing that it wasnt drawing the battery down and I would have to flip the key on and off a few times to get it to kick in, when I did this the truck started up great, cleaned up the connection ect and so far so good, no problems yet.

not sure if that was the problem of if something just fixed itsself, Ill probably pull the screen and check it just to be sure, but it was 50 degrees out when it was starting hard I find it hard to belive that the glow plugs make that huge of a difference in 50 degree weather.

thanks again
 
1 - 3 of 3 Posts
Top