Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey guys ive got a 08 6.4 with the mods listed in my sig. Ive been having some problems with my truck so I returned to stock and Im still having them. I looked in the sticky for my codes and they were not listed. I did a search for them and found a thread where one of them was related to a blown fuse (b2900) I checked my fues with a test light and they are good. I changed the oil and fuel filters about 200 miles ago and have had the dpf back on since I changed the oil. If any of you have had this problem please let me know what the fix was. This is my only mode of transportation and if something is seriously wrong I dont want to drive it all weekend and mess the truck up more. The truck is completely stock right now. Stock air filter exhaust and no tuner. I do still have my gauges in due to my dog chewing up my apillar handle. (stupid dog) Another thing is do you guys think the dealership will void my warranty because of gauges?

Here is my codes: B2900, U2011, U0115, U2511, U0100, U0101, U0100 (twice)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
:bump::bump::bump::bump::bump::bump:
 

·
Premium Member
Joined
·
1,489 Posts
Here is my codes: B2900, U2011, U0115, U2511, U0100, U0101, U0100 (twice)
B2900 = Left Turn Indicator output failure
U2011 = Invalid/fault data received
U0115 = lost communication with ECM/PCM "B"
U2511 = CAN communication bus fault
U0100 = lost communication with ECM/PCM "A"
U0101 = lost communication with TCM

It sounds like your computer is on the fritz. I wouldn't be afraid of running it. It isn't something that running is going to hurt. It will either work or not work. It definitely needs to go to the dealership for repair.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
B2900 = Left Turn Indicator output failure
U2011 = Invalid/fault data received
U0115 = lost communication with ECM/PCM "B"
U2511 = CAN communication bus fault
U0100 = lost communication with ECM/PCM "A"
U0101 = lost communication with TCM

It sounds like your computer is on the fritz. I wouldn't be afraid of running it. It isn't something that running is going to hurt. It will either work or not work. It definitely needs to go to the dealership for repair.
Hey thanks! Where did you find those codes? All the code list I could find only listed a few of the "U" codes

If you let me know where you found that Illl get a mod to update the sticky.
 

·
Premium Member
Joined
·
1,489 Posts
Hey thanks! Where did you find those codes? All the code list I could find only listed a few of the "U" codes

If you let me know where you found that Illl get a mod to update the sticky.
I have a software program that came with an Innova Equus 3130 scanner I bought. There is a code library in the software.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Hey guys I took my truck to the dealer and they didnt find anything wrong with it. Should I take it to another dealer or just drive it to the ecu completely takes a dump.
 

·
Registered
Joined
·
6 Posts
This helped me out, as well- seems it is an issued related to the SCT tuner- I have one too, running a custom race tune. I restored to stock and then reprogrammed and the problem is gone. Thanks!

H8rmkr665hp6.4
 
1 - 11 of 11 Posts
Top