Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
This evening my truck was acting up and was telling me the engine temp was high. I tried flipping my heat on to see if that would bring the temp down till i found a place to safely stop. only thing is the heat would not kick on so finally i got pulled over and temp went down. Sounds to me like a stuck thermostat but I am not 100% sure. the motor is making a straining noise that ive never heard before til today. hooked my SCT tuner up and ran a data log. Coolant temp was only running 10* higher than Normal temps. if anyone can offer any insight to possible fix and or diagnosis please let me know.

Running a 07- 111500miles, intake, exhaust and canned SCT tunes
 

·
War is the answer!
Joined
·
5,398 Posts
Codes? What way the temp? When was the last time you changed the thermostat? Coolant level?

Sent from my SPH-L710 using AutoGuide.Com Free App
 

·
Registered
Joined
·
4,914 Posts
Codes? What way the temp? When was the last time yoyo cganfwd the thermostat? Coolant level?

Sent from my SPH-L710 using AutoGuide.Com Free App
War child, you need some coffee, or I need to yoyo cganfwd my thermostat too. Hehehe

Sent from my phone that somebody didn't help me get.
 

·
War is the answer!
Joined
·
5,398 Posts
War child, you need some coffee, or I need to yoyo cganfwd my thermostat too. Hehehe

Sent from my phone that somebody didn't help me get.
Lol ....coffee would be nice. 12 hour shifts are a b1tch sometimes. This time it's auto correct though.

Sent from my SPH-L710 using AutoGuide.Com Free App
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Codes? What way the temp? When was the last time you changed the thermostat? Coolant level?

Sent from my SPH-L710 using AutoGuide.Com Free App
Only code being shown is P00000 which has been checked by dealer with nothing found. I bought the truck used with 87k and haven't changed the thermostat. Coolant level is good.
 

·
War is the answer!
Joined
·
5,398 Posts
I would try replacing he thermostat and check to make sure your fan is running if you still have issues replace the radiator. That is pretty much all you can do. If you were losing coolant I would say head gaskets. Hw hard are you running it when it over heats? Do you have a monitoring solution to see what your temps are exactly? If not then that is your new first step.

Sent from my SPH-L710 using AutoGuide.Com Free App
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
finally got a good look under the hood with my mechanic. Obvious blown water pump. so replaced that and the thermostat. coolant flush and new coolant. all in all better than what it could have been.
 
1 - 7 of 7 Posts
Top