Ford Powerstroke Diesel Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
I hope I am posting this in the right place, I am new to PS.org.

I have a 1999 F250 SD with 7.3PS, 373,000 miles was running strong and one day just died. I finally got it started again and it lopes really bad up and down between around 400 and 900 rpm at idle but only for a few seconds then dies. If i press the accelerator pedal to the floor it will rev but max out at around 2000 RPM and blow white smoke like crazy. I have replaced the IDM... twice, UVC harnesses and Gaskets.I took it to ford and they told me my IDM was bad and all injectors needed replaced.I have quite a bit of diesel experience but this has me stumped. I am sure the injectors are a little worn,however i ran a buzz test on auto enginuity and they sounded okay to me. The truck sounds like it is only firing on a few cylinders.I cant run a cylinder contribution test as the truck wont idle long enough without hitting the accelerator which cancells the test. The ICP was reading around 2400 PSI. I don't want to replace the injectors if there is something more serious wrong with the truck. I just dont see that many going bad all at once. it doesnt smoke unless you have your foot to the floor ( if i get it up to 2000 and let off a little it stops smoking).

A little background... It has been really hard to start for a long time ( if it was cold and it wasnt plugged in forget it) and had developed a small miss.

Also when i pulled the codes last night i got 5 P1293,P1294, P1295, P1296, P1298

Any help would be greatly appreciated!!!!!

Thanks
 

·
Registered
Joined
·
2,902 Posts
when u start it, how many seconds til the oil pressure gauge moves? 3 seconds or quicker is cool. If its like 6 seconds let me know
I would also want to know if you ever replaced the injector Orings?
try idling with the icp sensor unplugged
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
The Oil Pressure comes up almost immediatly, The ICP has a duty cycle of 14% with the truck shut off is that normal? I am also now getting a P1668 code. but this is the third IDM and it still runs the same.
 

·
Registered
Joined
·
2,902 Posts
can you run he key on engine off tests and get any other codes?
where are the idm's u r using coming from? Do you know they are good?
did you use ford uvch's or aftermarket? Aftermarket is junk for these parts.
Any chance the ipr is sticking and not allowing hpop pressure?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
The 4 codes i listed came from the KOEO test. The first IDM was the original, the second was a Re-man from auto computer exchange, and the third was a replacement from auto computer exchange. I user an aftermarket uvch kit. but have ohmed it and they are good. Im not sure about the IPR can i just remove it and clean it out or would it need replaced? Also, I unplugged the ICP sensor yesterday and it basically ran the same, however i cleaned the contacts on it and plugged it back in and cleared the code and now the truck will not rev past about 650 RPM's! so it is worse. I ran the buzz test again and during its clicking cycles it would seem to stutter a little bit.
 
1 - 9 of 9 Posts
Top