Ford Powerstroke Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I HAVE 06 F450 WITH A 6.0 IT WONT START. DURING CRANK WITH IT HOOK UP TO SCANNER ONLY GETTING 54 RPM I REPLACE THE CRANK SENSOR AND CAM SENSOR ANYONE KNOW WHAT THIS CAN BE PLEASE HELP
 
Joined
·
1,023 Posts
High pressure oil leak. Dummy plugs or stand pipes. Scanner give you any info what its reading for ICP pressure, How about codes? If a bad ficm occurs it will throw a Circuit low codes for the injectors P0611 Ficm performance, and codes for cam/crank sensor and sometimes ICP as well.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
I replace the ficm I had got a code open circuit for the crank sensor. Test icp I have .8 volts and did the air test new head gaskets standpipes and dummy plugs I put in a new starter and the rpm went up to 90 and than drop down to 30 and back up
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
I replace the ficm head gasket stand pipe dummy plug I have .8volts from icp I have 1 code for open circuit for crank sensor
 

·
Premium Member
Joined
·
1,975 Posts
Is this the same truck that will run if you give it a shot of ether?

It would really be helpful if you just kept one thread going. You have 5 threads on the same issue but you never responded to my questions.
 

·
Registered
Joined
·
2,254 Posts
Are you sure the crank sensor is seated fully? I had a similar issue and it turned out the crank sensor was a hare too short-caused an intermittant/erroneous rpm signal.

Remove/clean the crank sensor and grease the o-ring. Put the sensor in and tap it to make sure it seats fully.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
Is this the same truck that will run if you give it a shot of ether?

It would really be helpful if you just kept one thread going. You have 5 threads on the same issue but you never responded to my questions.
yes it the same truck sorry for all threads i am new to this
 
Joined
·
1,023 Posts
Okay heres a few issues you will run into with swapping engines...

I assume Dazdillenger and Sinner6.0 are also ford techs maybe they can back me up on this Along with MChan.

If you got an engine not within the build date of your engine, it is VERY possible that the connector on the PCM and FICM can be different. I found this on a side job i did for a guy and i told him the engines may be both in 06s but the build dates and sensors and connectors may be just different enough to cause a whole bunch of things. Needless to say i pulled my hair out for weeks until it ran and drove then the issue it had was glow plug light always on and water in fuel light always on.

Now as for the truck not running-Make sure the standpipes are seated fully. Make sure the connectors are all snug on the wiring harness, make sure the crank and cam sensors are the SAME exact same! in measurement, in pin size and location, and make sure it doesnt have any signs damaged pins on both female and male ends.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #13
Okay heres a few issues you will run into with swapping engine
I assume Dazdillenger and Sinner6.0 are also ford techs maybe they can back me up on this Along with MChan.

If you got an engine not within the build date of your engine, it is VERY possible that the connector on the PCM and FICM can be different. I found this on a side job i did for a guy and i told him the engines may be both in 06s but the build dates and sensors and connectors may be just different enough to cause a whole bunch of things. Needless to say i pulled my hair out for weeks until it ran and drove then the issue it had was glow plug light always on and water in fuel light always on.

Now as for the truck not running-Make sure the standpipes are seated fully. Make sure the connectors are all snug on the wiring harness, make sure the crank and cam sensors are the SAME exact same! in measurement, in pin size and location, and make sure it doesnt have any signs damaged pins on both female and male ends.
the motor i put in is a 04 we used the 06 sensors and hpop and wiring harness
 
1 - 13 of 13 Posts
Top