Ford Powerstroke Diesel Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
hey guys need a little help my 6.0 is bucking like crazy in overdrive till the turbo spools up and it only does it in overdrive i dont know where to start (egr,injectors) any help would be greatly appreciated thanks in advance.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #2
bump:confused:
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
someone has had to experience this before
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
maybe some techs are on this time of day
 

·
Registered
Joined
·
589 Posts
mine did almost the same thing. First I lost fuel pump then injector and figured that was it. Got it done went out still did it. Turns out was the egr valve. I hate to do it to but if you take it to ford they can tell you what the egr valve and injectors are doing. The egr valve is like $320 I believe so not like something you want to replace and it not be that. Id bet its the egr though.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
thanks redsmoke its weird you say that because i replaced the fuel pump 3 months ago and a injector two months ago. thanks for the help i will try the egr valve and let you know.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
wasnt the egr valve brand new one in still doin the same thing
 

·
Registered
Joined
·
589 Posts
no as soon as I put the new egr valve in it cleared up and quit doing the bucking. It was just a long list of other things that went out before I realized and pin pointed the egr valve. I also tried doing the cleaning trick on it and didnt work worth a crap. You can try it but Id bet you go buy a new one.
 

·
Registered
Joined
·
589 Posts
now I got a new one im trying to figure out. When I take off not completly warmed up it cuts out and runs like crap. Floor it it clears out. Soon as it warms runs like a champ. Thinking of cleaning the turbo but turbo doesnt fluctuate when it cuts out so dont think thats it.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #11
i was wonderin about turbo but leaning more towards injectors right now have to do something because right now in the hight gears if i get on it bucks and blows black smoke everywhere
 

·
Registered
Joined
·
589 Posts
So you put in a new egr valve or not. Cause thats what mine did when it was just the egr valve. When I lost my injector it idled like a gasser with a couple plugs fould and ran like one to taking off. It didnt blow smoke though.
 

·
Registered
Joined
·
589 Posts
Got a question for you. What egts do you have with you sct and have you had any problems with you headstuds being stock yet.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #14
yeah i put a new egr in and still the same symptoms and its idling fine just acts like its missing in the high gear and will buck until my rpms get up to about 2. with the sct the highest my egts get is about 1200 normal driving they stay anywhere from 8 to 1000.
 

·
Registered
Joined
·
589 Posts
I run diesel kleen every tank. This do the same as that stanadyne right. I also run tranny fluid every tank cause of the ****ty diesel these days.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #18
just a little update what my problems were leaky y pipe loose connection on ficm loose connection on icp sensor and bad maff sensor and the loose connections shorted out all three sensors in all 2300 worth of repairs just now figured out all the problems.
 
1 - 18 of 18 Posts
Top