Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
186 Posts
Discussion Starter #1
Have a 2016 XLT Lariat blah blah blah,,, loaded.
Left Raleigh NC yesterday morning and got half \way to northeast Ohio and my Navigation went out. Wouldn't load/open, then would start to load then go back to home screen. Tried getting it going the next 4 hours to no avail. Came home today and after trying for 5 hours, it started working normal 4 hours from the house.
Also, I use bluetooth for music from my iPhone and the entire time driving there and back, it sounds like the music is hitting a skip, like a record player would do 40 years ago. Remember them some of you? Would happen every few minutes then play decent for 20-30 minutes then do it again every few minutes.

My fear is the unit is going bad. It did this shortly after I bought it new in August 2016 but then worked fine since so I thought it was old man operator error.

Now it's over 3 years old, 33,000 miles and probably out of warranty?
 

·
Super Moderator
Joined
·
9,623 Posts
Have you tried to reset the system?? For me it's hold the > (scan???) button with the power button. After a few it will start the reset/restart process. Do not try this while driving, and verify the correct buttons with your system and the owners manual.
 

·
Registered
Joined
·
460 Posts
Also try updating it. They have periodic updates that need to be preformed. You used to be able to do it yourself online but now you have to go to the dealer

Sent from my SM-G975U using Tapatalk
 
1 - 5 of 5 Posts
Top