Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
just finnished up my truck this weekend installed a new oil cooler, egr delete, turbo drain tube, coolant filter. i cleaned the turbo while i had everything appart, put anti seize on all the components inside the turbo. got everything back together and fire it up sounds ok no leak looks good. i hop in for a drive as im backing outta the driveway i hear the turbo spin up and make this horrible sound. faster the turbo spins louder the whining sound is. so i drive back into the garage, and begin removing stuff and check the y pipe v band clamp. looks like its a nice seal so i put it back together tighten everything back up and get the same results. i got a video of the sound, any info on this would be great.

 
Joined
·
1,023 Posts
put anti seize on all the components inside the turbo.
:doh::doh::doh::doh::doh::doh::doh::doh::doh::doh::doh::doh::doh::doh::doh:

I did this once and never again. What happens is the crap gets hot liquifies and slings around inside the compressor housing. Take it all back apart and CLEAN IT ALL OUT! hopefully you didnt cause the compressor wheel to become out of balance and score against the housing! I had that happen i figured the noise would eventually go away... Got worse and worse and worse and i got mad and held it wide open and ended up having the turbo come apart and shoot oil and the compressor wheel down the down pipe.... THANK GOD i got that covered under ESP...
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
ahhhh thats sucks hope i didnt mangle anything geuss i still got some work to do :doh: thanks for the info
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Ok wtf riped turbo out today cleaned it all out put it back in, still getting the same noise. Almost seems like the truck isnt boosting up properly when i foot brake it. maybe an exhaust leak/ crack on y pipe could cause this???
 
1 - 4 of 4 Posts
Top