Ford Powerstroke Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
6,782 Posts
Discussion Starter #1
I have some things to say about my truck. First off the fuel gauge pisses me off. The low fuel light never comes on and it gets stuck below empty every once in awhile. It also gets 11 MPG going 70 mph on the freeway. The door sqeeks, every time I roll the passanger window down it sweeks also, rear window gets binded and is a pain to open/close, the pin hole on the trailer hitch is ovaling. It does 0-60 in 12.5 Sec. It doesn't stop to well. Tranny slips. Everytime I put the truck in reverse it slams into to reverse (feels like getting rearended) and then it delays when putting it into drive and when it goes into gear it makes a clunk grinding noise.
 

·
Stupidity pisses me off
Joined
·
3,863 Posts
Hey man you got a 6.0, :dunno: what else is there to say :icon_ford:
 

·
Stupidity pisses me off
Joined
·
3,863 Posts
Wish it had a 7.3.
Hey we have plenty of problems also. At least you have the benefit of them all happening at once so you know whats going on. Everytime I get something done, something else happens. But I guess thats just trucks that are used for more than home decorations :dunno:
 

·
Registered
Joined
·
1,304 Posts
Hey man you got a 6.0, :dunno: what else is there to say :icon_ford:
You couldn pay me to get rid of my 6.0.... He didn say there was anythin wrong with the motor:dunno:.... Sounds like you got a lemon.... Why not sell it???
 

·
Registered
Joined
·
6,782 Posts
Discussion Starter #6
You couldn pay me to get rid of my 6.0.... He didn say there was anythin wrong with the motor:dunno:.... Sounds like you got a lemon.... Why not sell it???
Already got the truck the way I like it. If I were to sell it I wouldn't be able to get another PSD. This one came at the right time when I got it. I'm in a battle with Ford to try and get the tranny fixed.
 

·
Registered
Joined
·
1,304 Posts
Well I hope you get it all figured out.. Cuz you got a sharp truck.... Hang in there
 

·
Compression Ignition Addict
Joined
·
6,293 Posts
First - sorry you are having problems.

Second, the torqshift is a VERY reliable transmission - for most they are providing excellent reliability.

Last - these injectors do not like low fuel pressure. If you are continually running to empty (or near empty), you are taking unnecessary risks and the repair costs can be huge. From what you have said, I assume that the fuel gage works properly until it gets below empty. If it works well until you get to the low level - why let it get that low??

There is a known issue that I haven't read about recently. The issue is problems w/ your fuel gage if you fill up with the truck running. It eventually resets. Won't have the problem if fueling w/ engine off. Don't know if this is your issue, but based on a previous post, it seems that this was happening to you.

12.5 seconds for 0-60 isn't that bad for a stock 8000lb + truck. My truck is running well and does it at 12 seconds - maybe a tad under. Do you have any mods? What codes are you getting on your transmission?
 

·
Registered
Joined
·
203 Posts
I have some things to say about my truck. First off the fuel gauge pisses me off. The low fuel light never comes on and it gets stuck below empty every once in awhile. It also gets 11 MPG going 70 mph on the freeway. The door sqeeks, every time I roll the passanger window down it sweeks also, rear window gets binded and is a pain to open/close, the pin hole on the trailer hitch is ovaling. It does 0-60 in 12.5 Sec. It doesn't stop to well. Tranny slips. Everytime I put the truck in reverse it slams into to reverse (feels like getting rearended) and then it delays when putting it into drive and when it goes into gear it makes a clunk grinding noise.
Didn't you have a programmer in the past? Also, did you recal the speedo for having 35's?

Try lubricating the door and windows...

Odd that the hole in the trailer hitch is ovaling. Shouldn't be too hard to reinforce/swap out though.

It's a 7500lb truck, not a porsche

As for the tranny: Most people like the torqshift, so you might just have some sort of lemon/abused (see programmer question)
 

·
Registered
Joined
·
6,782 Posts
Discussion Starter #10
First - sorry you are having problems.

Second, the torqshift is a VERY reliable transmission - for most they are providing excellent reliability.

Last - these injectors do not like low fuel pressure. If you are continually running to empty (or near empty), you are taking unnecessary risks and the repair costs can be huge. From what you have said, I assume that the fuel gage works properly until it gets below empty. If it works well until you get to the low level - why let it get that low??

There is a known issue that I haven't read about recently. The issue is problems w/ your fuel gage if you fill up with the truck running. It eventually resets. Won't have the problem if fueling w/ engine off. Don't know if this is your issue, but based on a previous post, it seems that this was happening to you.

12.5 seconds for 0-60 isn't that bad for a stock 8000lb + truck. My truck is running well and does it at 12 seconds - maybe a tad under. Do you have any mods? What codes are you getting on your transmission?
The fuel gauge isn't consistant some days right below a 1/4 the truck will take 23 gallons and some days it will take 27. One time it was on an 1/8 running fine and then I put 5 gallons in it and it took awhile to start and ran ruff.

Didn't you have a programmer in the past? Also, did you recal the speedo for having 35's?

Try lubricating the door and windows...

Odd that the hole in the trailer hitch is ovaling. Shouldn't be too hard to reinforce/swap out though.

It's a 7500lb truck, not a porsche

As for the tranny: Most people like the torqshift, so you might just have some sort of lemon/abused (see programmer question)
It did have a programmer but hasn't been on for 10K miles and still has all of the same problems. The truck had 2 tranny's when it was completly stock. The programmer didn't cause any new problems it just gave the truck more power and thats it. No one has an opinion on the 11 MPG.
 

·
Registered
Joined
·
203 Posts
Dunno. Either there is something fishy about the truck or you really beat the piss out of it. Has it ever been in a wreck? Do you tow ALL the time?
 

·
Registered
Joined
·
5,008 Posts
have you tried cleaning the egr valve? that might help your performance and milage out a ton!

as far as the rest of it goes I would take the truck down to ford with your lawyer and say Im coming to pick it up in one week and I want it FIXXED!!!!!!!!!!!!!!
 

·
Registered
Joined
·
6,782 Posts
Discussion Starter #14
IIRC from another thread, aren't you on your 4th or 5th 5R110 replacement?
5th

Dunno. Either there is something fishy about the truck or you really beat the piss out of it. Has it ever been in a wreck? Do you tow ALL the time?
Don't beat the piss out of it but drive it like a 6.0 should be driven*. I'm the first owner and it's never been wrecked. It tows maybe 400 miles a month.

* My definition on how a 6.0 should be driven. Don't drive like a grandma but don't drive it like a spoiled teenager. Cruise it and on a good straight open it up get it hot and cleaned out then back to cruising.
 
1 - 16 of 16 Posts
Top