Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
Also in the problems section where my thread is, figured id show some of my experience on this fairly commonly un-solved-on-the-forums issue (ive probably read 500-1000 threads where they dead ended)

ADVICE TO PREVENT SOME CONFUSION, IF YOUR 7.3 EVER MAKES A
LOUD "POP" FOLLOWED BY SOME CLANGING AND VIBRATING PULL YOUR DANG VALVE COVERS OFF FIRST AS WELL AS PULLING THE CODES!!!


Heres the verdict this far, pulled the valve covers off tonight, wanted to check that #4 cylinder code, and sure enough my soul was crushed.....my poor baby......




:shots::banging::banging::banging:

got two rods ready to be picked up in the morning, anyone know how to replace them, i sure as heck dont!

Also, another question, on the right rod side it seems as if it has "chewed" or bored out that hole that they sit in (im talking about the slot, not the actual grove on the bottom) the sleeve part going ino the head to help line it up, think its just gonna keep breaking them and i need a new head? anyone have experience with this im in need of MUCH ADVICE thanks in advance!
 

·
Banned
Joined
·
5,630 Posts
I'd be curious to know wtf caused them to break in the first place...
 

·
Registered
Joined
·
101 Posts
Discussion Starter #4
My personal opinion would putthe injector as the culprit some how, she didn't show any issues leadin up to that though so once I know I'll keep it posted here
 

·
Banned
Joined
·
5,630 Posts
thats not making sense to me....
 

·
Registered
Joined
·
101 Posts
Discussion Starter #6
I don't know the previous use of the truck
So it's possible she wasnt takin very h
 

·
Banned
Joined
·
5,630 Posts
Thats very true...
 

·
Registered
Joined
·
101 Posts
Discussion Starter #8
gonna call this guy tomorrow and practically beg him to take it so he can figure it out next week while im still in school, but eh well see what happens
 
1 - 8 of 8 Posts
Top